Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Exception from HRESULT: 0x80040E14

  Asked By: Rey    Date: Dec 04    Category: Sharepoint    Views: 22630

This message Exception from HRESULT: 0x80040E14] appears after we made a change
in a list and when we press OK. I did not find any remarks related to this
problem.


We are using WSS 3.0 with SQL 2005

Does anyone has info about this?

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Megan Martin     Answered On: Dec 04

For a good description on the various permutations that this HRESULT means,
see: http://www.adopenstatic.com/faq/80040e14.asp

In SharePoint V2, you would normally get this message  because of a failed
hotfix, or service pack upgrade which changed the Schema of the databases:

See: http://support.microsoft.com/kb/841216

I would imagine you could also get this message if you were upgrading WSS
B2TR to RTM. Was this the case for you? That you upgraded a B2TR build to
RTM?

 
Answer #2    Answered By: Donta Kirkland     Answered On: Dec 04

This morning our users told me they could no longer load documents into
any document library on SharePoint. The error message  to end users
read "The URL <whatever.doc>' is invalid. It may refer to a nonexistent
file or folder, or refer to a valid file or folder that is not in the
current Web." The real underlying error message was Exception from
HRESULT: 0x80040E14. When I searched for this error, I was led down the
wrong path by a Microsoft knowledgebase article (841216) which implied
it was caused by the improper application of a service pack or security
update to the SharePoint server. When I was able to prove to myself
that no change had been made  to the SharePoint server this morning
between the time when things succeeded and when they failed, I started
looking elsewhere for trouble. The real cause was that the content
database transaction log was full, and could not be expanded because
the disk drive was out of space. Once I cleared this database problem,
SharePoint started working again.

The reason the transaction log became so large might also interest some
of you. Recently we started using Symantec BackupExec 11d to back up
our SharePoint Portal 2003 data, because it provides single item
restore with documents in SharePoint document libraries, something hard
to achieve with Microsoft tools alone. I should have noticed that their
backup was backing up the databases but not the transaction logs, and
so no truncation ever occurred, resulting in a runaway transaction log
for the content database. I've set the database backup option to
Simple, since BackupExec will not back up a transaction log for a
database that is being backed up in the SharePoint set. I think that is
a flaw in Symantec's design, but the ability to restore a single item
with easy point and click by backup operators who know nothing about
SharePoint is worth the aggravation.

 
Answer #3    Answered By: Karthik Seema     Answered On: Dec 01

This error is because of not sufficient space in the SQL server disk, make some space it works fine.

 
Answer #4    Answered By: Prett Sons     Answered On: Mar 15

Agreed with Megan Martin. If after applying all steps that describe in http://support.microsoft.com/kb/841216 this link still get same error then i will suggest you to try SharePoint Recovery Tool. Check this link for more information:
http://www.sharepoint-server-recovery.com/

 
Didn't find what you were looking for? Find more on Exception from HRESULT: 0x80040E14 Or get search suggestion and latest updates.




Tagged: