MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Excel Web Access Webpart Error

  Asked By: Harley    Date: Sep 28    Category: MOSS    Views: 8309

I have a small farm that is configured with SharePoint 2007. Within
the farm there is one App Server; 2 front end servers; a SQL 2005
server and an Index server. I have the Excel Calculation Services
configured to run on the Index server. I have an Excel Web Access
webpart on one of the pages on the Appserver front end. I have the
trusted locations setup to point to a document library and I have the
Excel Web Access webpart pointing to an excel book in that location,
however, I always receive this error "Unable to load workbook". Any
thoughts anyone?



7 Answers Found

Answer #1    Answered By: Cory Brooks     Answered On: Sep 28

Did you add the location of the excel  file to the trusted file

If so, I would try restarting the service.

Answer #2    Answered By: Ruth George     Answered On: Sep 28

Yes I have tried to add just the document
library path to the trusted file locations and then I added the document
library path and the file name to the trusted file locations --- and I did
restart the service - but nothing has helped. I still receive the same

Answer #3    Answered By: Peter Peterson     Answered On: Sep 28

If it is in a document library, what happens when you try to view it
from the properties drop-down? I usually try to get it working there
first. Someone sent me this nifty link earlier in the week.


Answer #4    Answered By: Kalyan Pujari     Answered On: Sep 28

I can select any book.xml from the document library and view the file
fine. However, because I have Excel installed on my desktop the document is
displayed within the Excel client.

Answer #5    Answered By: Isidro Berger     Answered On: Sep 28

I tried the tool against the file and I get the following error: IRM
permissions issue. Any idea what this may be?

Answer #6    Answered By: Schuyler Le     Answered On: Sep 28

Appears the spreadsheet was authored in an environment with a Rights
Management Server enabled. Is this configured  in Central Administration?

If not, it is file level and I don't know how to fix it, sorry.

Answer #7    Answered By: Kristina Cox     Answered On: Sep 28

If you select 'View in Web Browser' in the document drop down, it
should not open in Excel. If that is missing, then you might have
another problem.

Didn't find what you were looking for? Find more on Excel Web Access Webpart Error Or get search suggestion and latest updates.