MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Excel files with macros error out in search

  Asked By: Tyson    Date: Jan 11    Category: MOSS    Views: 2473

First, I've got my MOSS medium server installation running fine (almost :-)
), in part because of the information shared here by the members of this
group, a big thanks to everyone.

Now, one last sticking point:

My MOSS search errors on Excel files that have macros embedded. I've tried
to look for other file level identifiers but that seems to be the only
distinct property about the ones that are throwing an error. I get two
errors in the crawl log:

1. The specified network name is no longer available. (Exception from
HRESULT: 0x80070040)
2. The docfile has been corrupted
Both of these errors are on Excel files with embedded macros (nothing
apparent that would cause one error over the other). I can click on the link
from the error log and the file will open just fine, but obviously will
never be displayed to the user because it's not indexed. Anyone else
experienced this?



6 Answers Found

Answer #1    Answered By: Angarika Shroff     Answered On: Jan 11

I have this very same issue and I have also attributed it to macro-enabled Excel
files. Not sure if there is a workaround, but the file  opens fine  for me, too.
It just doesn't get indexed.

Answer #2    Answered By: Micheal Knight     Answered On: Jan 11

so I'm guessing this is something to
address with Microsoft. This client has LOTS of Excel files, most with
macros embedded  so this is close to a deal breaker for them.

Anyone know of a workaround or if MS is aware of this issue?

Answer #3    Answered By: Lesley Tate     Answered On: Jan 11

I assume it is failing based on Macros, because Excel and IE won't open  a
Spreadsheet that contains macros in Excel without user  intervention. Having
said that have you tried logging in as the content crawler account for the
farm and adjusting the security zone for the site in IE and Excel to allow
opening spreadsheets even with untrusted macros. I suspect somewhere deep
down the crawler is using the same engine.

Answer #4    Answered By: Chris Daniel     Answered On: Jan 11

Just a further follow-up to this. I created 3 spreadsheets last night, an
xls, an xlsm, and a xlsx. After storing them in a document library on the
SharePoint 2007 and forcing an Index crawl  I was able to search  on the
contents of all 3 files  without a problem. Both the XLS and XLSM files had
a simple word macro stored in them.

Results were the same on the WSS site that I have on that server. So I have
not been able to replicate the issue of MOSS not being able to index Excel

There are several differences between my test environment and yours. I
don't have access at the moment to a Medium farm, mine is a single server
environment. Also, my single server  has Office 2007 installed on the
server. Not sure if either of these could cause the difference between what
you are seeing and what I am seeing, but its possible.

Answer #5    Answered By: Lynn Mann     Answered On: Jan 11

That is one significant difference - I do not have Office installed on the
server. I will install it on the index server  to see if it resolved this.

Answer #6    Answered By: Damini Dande     Answered On: Jan 11

No, I do not have it installed there. Let me know if that resolves your issue.
That would surely be an easy fix.

Didn't find what you were looking for? Find more on Excel files with macros error out in search Or get search suggestion and latest updates.