Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Error Starting Web Application Service (SPWebService)

  Asked By: Leslie    Date: Dec 19    Category: Sharepoint    Views: 8895

Can anyone help me with a SharePoint "Web Application Service" problem on a
brand new front end web server? I'm not sure what account it is using and what
else to give it access to in order to allow it to start.

I added a new web front end to an existing MOSS farm and the Web Application
Service (SPWebService) entry in "Services on Servers" from Central Admin says it
has an "Error Starting."

Attempts to start it manually using stsadm provisionservice only succeed in
getting it to say STOPPED and then ERROR STARTING again. STSADM
enumerateservices lists the service as "disabled." The error log contains event
ID 7034 for the new server with no associated user and the text "Could not find
a part of the path 'e:\Program Files\Common Files\Microsoft Shared\Web Server
Extensions\12\Logs'." (NB: This path does exist) The hive 12 ULS log seems to
indicate that there is a problem accessing the registry.

Does anyone know how I can determine what account the WSS Web Application
Service is using, and how I give it whatever access it needs to resolve these
errors and start properly?

Details:

Unified logging contains the following seemingly related entries ...

11/10/2008 16:02:57.54 OWSTIMER.EXE (0x1384) 0x0EC0 Windows
SharePoint Services Topology
88bl Monitorable An exception occured while trying to acquire the
local farm: System.Security.SecurityException: Requested registry access is not
allowed. at Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean
writable) at
Microsoft.SharePoint.Administration.SPConfigurationDatabase.get_RegistryConnecti\
onString() at
Microsoft.SharePoint.Administration.SPConfigurationDatabase.get_Local() at
Microsoft.SharePoint.Administration.SPFarm.FindLocal(SPFarm& farm, Boolean&
isJoined) The Zone of the assembly that failed was: MyComputer

11/10/2008 16:02:57.54 OWSTIMER.EXE (0x1384) 0x0EC0 Windows
SharePoint Services Timer
5utx Unexpected The timer service could not initialize its
configuration, please check the configuration database. Will retry later.

0x12F0 Windows SharePoint Services Topology 0 Unexpected
Unable to unprovisioned metabase object
IIS://localhost/w3svc/AppPools/SharePoint - 7502:
System.Runtime.InteropServices.COMException (0x80070003): The system cannot find
the path specified. at
System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail) at
System.DirectoryServices.DirectoryEntry.Bind() at
System.DirectoryServices.DirectoryEntry.get_AdsObject() at
System.DirectoryServices.DirectoryEntry.DeleteTree() at
Microsoft.SharePoint.Administration.SPMetabaseObject.Unprovision()

0x0128 Windows SharePoint Services Topology
8zoh Critical An attempt to start/stop instance of service Windows
SharePoint Services Web Application on server MYPORTAL did not succeed. Re-run
the action via UI or command line on the specified server. Additional
information is below. Could not find a part of the path 'e:\Program
Files\Common Files\Microsoft Shared\Web Server Extensions\12\Logs'.

Share: 

 

No Answers Found. Be the First, To Post Answer.

 
Didn't find what you were looking for? Find more on Error Starting Web Application Service (SPWebService) Or get search suggestion and latest updates.

Related Topics:



Tagged:            

 

Related Post