Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Error With Lookup Fields

  Asked By: Dario    Date: May 01    Category: Sharepoint    Views: 1035

I am getting an unusual error when using lookup fields in an STS site.

I have two lists in the site - one called Companies and one called contacts. The contacts list has a field called Company, which I made a lookup to the Company list.

In a web part on the home page, I display the contacts list, and I am grouping the contacts by the lookup field Company.

As expected, the web part displays the following:

+ Company: Company 1 Name (4)
+ Company: Company 2 Name (8)
+ Company: Company 3 Name (12)

But, for some reason, when you click on the link for a company name next to the + sign, the link takes you to an error page and displays the following message:

"This form is not available for this list, discussion board, survey, or document library."

I Googled and MSDNed the error message, and the only hits I came up with are knowledge base articles having to do with uploading a document to a document library.

Further adding to the strangeness is that on the All Contacts view page, I also display using a Group By Company, and it displays without any problem.

So then I tried clearing out the Company field in all entries in the Contacts list and starting over. I was able to re-select the company in the first several fields, and then jumping back to the home page, it displayed properly. After re-entering the information for each of the first several rows, I re-checked the home page, and it continued to display without error.

So then I went and re-entered the information for each of the rest of the entries, and somewhere along the way, I broke it again.

Does anyone have any ideas?


Further adding to the strangeness, 18 seems to be the magic number.

I once again cleared out all of the Company selections, and one-by-one, re-assigned them to see when it would break.

I made it through the first 17 contacts, and it continued to work. When I assigned the company to the 18th contact, it broke. So I then unassigned the 18th contact, and it worked again.

So then I wondered whether 18 was in fact a magic number, or if the entry that happened to be 18th in the list was the culprit.

So I skipped the 18th one, and assigned a company to the 19th one. Sure enough, it broke.

So then I went back and un-assigned one of the earlier entries, and sure enough, it was fixed again.

Share: 

 

1 Answer Found

 
Answer #1    Answered By: Monte Cooley     Answered On: May 01

I don't know about this theory of 18, however in response to your original post, try this - add the group field  to your view  (as a test case) where your have contacts  and the error  that you are getting will go away ( as when you click  on group  heading it will take you to the actual link's destination (company)).

If above holds true, you can leave the company  name in the view along with the contact  name or if this is un acceptable, you can convert the view to XLST view and that bad link  will go away.

I may be off here but I don't remember seeing this bug in Pre SP1 installations. Probably it has been introduced in SP1 and to be fixed  in SP2.

 
Didn't find what you were looking for? Find more on Error With Lookup Fields Or get search suggestion and latest updates.




Tagged: