Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Error installing a web part that was packaged via WPPackager

  Asked By: Holly    Date: Oct 05    Category: Sharepoint    Views: 898

I’m trying to install a Web Part (packaged up in an MSI via WPPackager) to one of my WFE boxes. The MSI has been installed on other servers with no problems prior, so I know the file isn’t corrupt (it’s the v1 SmartPart). When I go to install it, I’m prompted to install it to the GAC, and then to modify the CAS policy
(which I say [NO] as I want it to use the default properties used when installing something into the GAC)… at this point I get a terminating error and the install rolls back. No DWP, DLL, or SafeControl is found where they should be (/wpcontrols, GAC, and web.config)… When I open the wppackager.log, I see this:

========= WPPackager install log started 1/6/2006 3:46:26 PM =========

1/6/2006 3:46:34 PM: Error: User did not accept CAS settings for assembly 'SmartPart, Version=1.0.0.0, PublicKeyBlob=[omitted for brevity]' on virtual server 'http://[mySharePointDNS] /'.

Ideas? I didn’t find anything in the msft.public.wss.dev NNTP or just a standard Google search and had no hits.

I’m trying to install the Web Part on a portal that was just restored into a new environment and I’m now at the point where I’m installing their Web Parts. Not sure if that changes anything, but I figured I’d mention it just in case. I’m assuming I could always install it manually by placing files in the correct spots (assuming the Web Part registration information is in the DB post restore)… but I’d rather know why the install is failing.

Share: 

 

10 Answers Found

 
Answer #1    Answered By: Cassidy Sharpe     Answered On: Oct 05

If you use host headers to differentiate virtual servers  then you need
to install  WebParts into the GAC using WPPackager. Are you using host
headers?

www.bluedoglimited.com/.../ViewPost.aspx?id=83

 
Answer #2    Answered By: Linda Mason     Answered On: Oct 05

Even when the WP is deployed via a MSI (generated with WPP)? WPPackager will
install Web Parts packaged as MSI's? Didn't realize that

Yes, I believe we are using host headers in this environment.... but I'd have to
confirm... will post back  with details.

 
Answer #3    Answered By: Hans Weiss     Answered On: Oct 05

My experience is that Web Parts packaged with WPPackager do not seem to
deploy properly when using host headers. Try extending a Virtual Server
using a port number and then redeploy.

 
Answer #4    Answered By: Damon Garner     Answered On: Oct 05

After removing the host header, I still see the same error… even reset IIS. Or must the host header not be present when you extend the virtual  server (again, this is from a restore).

 
Answer #5    Answered By: Freddy Heath     Answered On: Oct 05

Still seeing the same error… here’s what I’ve done:

·  restored  the portal  with a Virtual Server (VS) configured with host headers – install  failed
· Removed host header from the VS after restoring the portal – install failed
· Made sure there were no host headers in the VS before restoring a portal, then restored – install failed
· Run EnumWPPacks via STSADM to see what’s installed… no web  parts installed

Any other ideas?

 
Answer #6    Answered By: Joanna Dixon     Answered On: Oct 05

AC: You could work around the problem in a less aggressive way than placing  the files  in the right spots… if I remember correctly, the CAB file  is in the MSI. You could use a tool like Orca (One Really Cool Application) which is included as a part  of the platform SDK to extract the CAB file and install  it manually.

It would at least tell you if there’s something about the CAB file that is causing issues (I doubt it but it’s  worth looking into.)

 
Answer #7    Answered By: Gopal Jamakhandi     Answered On: Oct 05

I opened the MSI with WinRAR and didn’t see a cab… only what the attached SS shows.

Brute force deployment is mw option right now… if I could only get the DLL & DWP’s

 
Answer #8    Answered By: Christop Mcfadden     Answered On: Oct 05

I’d extract the one identified as WebPart rename it to .CAB and see if it opens. I think WinRar is just showing the stream names in the MSI. That doesn’t match the file  name that is used.

If that doesn’t work send me the file off-list and I’ll crack it with Orca. I can work backwards through the streams and figure out which stream is the CAB file.

 
Answer #9    Answered By: Cory Brooks     Answered On: Oct 05

now I see the manifest, DLL, and DWP. Manual install  works…

where is Orca? I looked through my SDK and couldn’t find  it…

 
Answer #10    Answered By: Ruth George     Answered On: Oct 05

Orca is in the installer part  of the SDK. Its home page is here … msdn.microsoft.com/.../orca_exe.asp

Right now it looks like the only way to get to the Installer SDK part of the platform SDK is to use the web  installer which is here www.microsoft.com/.../details.aspx

 




Tagged: