Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Error deploying web parts in a cab

  Asked By: Demarco    Date: Jul 01    Category: Sharepoint    Views: 1045

Ok, I'm stumped. I've had this problem before, but I can't remember the exact steps I took to fix the problem.

I've created a cab with my web parts, I deploy it to our development server using stsadm win, it deploys, they show up in the catalog, but when I try to add them to the page I get the 'can't deserialize web part etc' error.

I've tried:

Deploying to the GAC
Not deploying to the GAC
Checked the permissions on the temp directory for the app pool account for portal server
Deployed it on my development machine fine.
Deployed it on a clean install of sharepoint fine.

Anyone remember what the trick is for this problem?



9 Answers Found

Answer #1    Answered By: Laura Walker     Answered On: Jul 01

Have you gone through the steps  in this article … http://www.devx.com/webdev/Article/29352/0

Answer #2    Answered By: Nina Banks     Answered On: Jul 01

Excellent article, I'm adding it to our teams Sharepoint knowledgebase.

The problem  was I was missing an assembly, and for some reason when I used STSAdm win  it wasn't naming the DWP files when it put it in the wpcatalog directory  with the full name since it was a signed assembly.

Answer #3    Answered By: Renee Murray     Answered On: Jul 01

I just had this similar problem. It happened when I
"commented out" the properties I didn't want in my web  part code.

Oh dear. I don't want these properties and if I take them out I get that
nasty serializable message too.

Answer #4    Answered By: Harshini Raju     Answered On: Jul 01

my problem  was solved by making the attributes in the web  part that
had been properties into "private" declarations.

I wonder if something similar is your problem?

Answer #5    Answered By: Christop Mcfadden     Answered On: Jul 01

Nope, I was missing a DLL that my web  part was referencing, and for some reason STADM win  didn't rename the DWP's properly when I deployed  it.

It's all fixed and working now.

Answer #6    Answered By: Gopal Jamakhandi     Answered On: Jul 01

Generally I get the serialization problems when I've already deployed  a web
part onto a page  and set the properties, then in code add  a new property,
remove one, change it's type, etc. That in effect changes the signature of
what's on the server  of the properties for that web  part. Generally deleting
the web part  instance and adding a new one works but YMMV.

Answer #7    Answered By: Chantal Rosa     Answered On: Jul 01

stsadm names the DWP based upon how you specify the assembly name in the
DWP. I highly recommend that you fully qualify your assembly in the DWP
before you create the CAB that you give to stsadm's addwppack operation
(even if you don't plan on doing a globalinstall which I typically

Answer #8    Answered By: Kyla Eckert     Answered On: Jul 01

I had, not sure why it wasn't naming it correctly. I kept uninstalling and reinstalling the cab  until it showed up correctly in the wpcatalog directory, took about 3 or 4 tries.

Answer #9    Answered By: Damon Garner     Answered On: Jul 01

I don't think that I've ever had that happen to me.

Didn't find what you were looking for? Find more on Error deploying web parts in a cab Or get search suggestion and latest updates.