MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Error creating web application - Absolute path information is require

  Asked By: Carmen    Date: Oct 04    Category: MOSS    Views: 6323

I made a typo when creating a new web application via MOSS Central
Admin - for the IIS Web Site path I accidentally left out the colon,
(e\inetpub\... instead of e:\inetpub\...). It went ahead to the
processing screen, then errored out with this message:

"Absolute path information is required."

It created an entry of it in Web Apps in Central Admin, though I get
the same above error when I try to delete it. It created the content
database, but not the IIS web site.

And now whenever I try to create ANY web application I get this error.

I have tried creating the IIS web site, extending/unextending/deleting
it via STSADM, removing the content DB and more but nothing is
working. Is there a way to change virtual directory paths which may be
my answer, or finding where it is referenced in one of the MOSS



5 Answers Found

Answer #1    Answered By: Julia Washington     Answered On: Oct 04

The first thing I would try is to re-run the configuration wizard with
no changes.

I think it will check the config db against existing configurations.

Answer #2    Answered By: Shashwat Takle     Answered On: Oct 04

Good idea to try, although that didn't fix it. Thanks.

Answer #3    Answered By: Aastha Acharya     Answered On: Oct 04

The only way I was able to fix this problem was by modifying the
Objects table of the config database, and removing  the rows
pertaining to the offending web  application (thet one where I forgot
the : in the path).

Search the 'Name' field for the web app name. There should be 1 row
for that web application. Before you kill the row, you must search
for all rows whose 'ParentID' is this row. Kill those first, then
kill the main web app row. It worked like a charm, however that web
app obviously was obliterated.

Another thing I tried was to edit the 'Properties' field for the web
app's row, as the e\inetpub\... was there, and I wanted to just
change it to e:\inetpub. However when I tried to select the field in
a query, it trucated the contents, so when I went to make an update
to it, I didn't have full proper contents of that field to update
back in. You may know of a proper way to do this, so it could

Be very careful in modifying your Sharepoint databases! Make sure to
back up any of them you decide to edit first!! If you run into any
errors after doing modifications, re-run the configuration wizard.

Answer #4    Answered By: Glenda Roth     Answered On: Oct 04

Oh also, if you happen to have a backup of your config database
before you caused this 'Absolute Path is Required' error, you can
just restore that. Then re-run the config wizard.

Answer #5    Answered By: Jada Clemons     Answered On: Oct 04

I am going through the same issue in my test farm. How did you resolve