Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Emailed Enabled Document Libraries

  Asked By: Russell    Date: Nov 03    Category: Sharepoint    Views: 813

Does anyone have any experience configuring email enabled document
libraries. I was able to sucessfully configure the Sharepoint side
for the virtual server configurations and the document library, but
I'm not sure how to configure the exchange side. I have admin access
to a public folder on Exchange. What do I need to do to configure



2 Answers Found

Answer #1    Answered By: Ross Watkins     Answered On: Nov 03

This is what I did and my email enabled  document library  is working fine by doing this.

To use this feature, you must use the Exchange 2000 server  administration tools to do the following:

Create the public  folder.
Grant read access to the appropriate Windows SharePoint Services application pool accounts. If you are using one account for all virtual  servers, grant that account access. If you are using separate accounts for each virtual server, you must grant the virtual server accounts access to the appropriate public folders.
If you prefer not to grant access to the application pool accounts, you can instead give the anonymous user account access to read the public folder. This is a less secure method than granting access to the application pool account.

Determine which e-mail distribution list to allow to post to the public folder, and grant the distribution list appropriate access to the public folder. Note that you will need to enable the public folder  to receive e-mail. This is not turned on by default, so the Exchange 2000 Server administrator will need to create an e-mail address for the public folder.
Continue to manage the public folder and the access to the public folder.

Answer #2    Answered By: Jeremiah Wallace     Answered On: Nov 03

We now have this working using E2K rather than 2003. You simply need the
correct permissions on the folder  so that the service account can pick
up the documents and then also that this is accesible via outlook
webaccess (a good test)

However....beware, if your exchange server  has the proper IIS lockdown
on W2K applied, it will actually block this action and the service
account will not be able to get the document  attachments to the wss
library...this was the subject of a 6 month premier call within MS and
makes me wonder what they originally tested it on....This is also needed
to make Mobile access work.

The fix for that is to change a verb within URLScan

1) Locate and edit the URLSCAN.INI on exchange  server, it is usually
located in the C:\WINNT\system32\inetsrv\urlscan folder.

Check that 'UseAllowVerbs' is enabled  in the [Options] section of the
ini file, should be 'UseAllowVerbs=1'.

2) Modify the [AllowVerbs] section of the ini file by adding the
following HTTP verb to the list of allowed verbs:


3) To apply the change, restart IIS Services.

Didn't find what you were looking for? Find more on Emailed Enabled Document Libraries Or get search suggestion and latest updates.