Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Editing Documents

  Asked By: Bhagavati    Date: Oct 12    Category: Sharepoint    Views: 673

I have a site where everybody is a contributor. I created a document library and
left the permissions as the default value. Users are able to go into this
document library to upload, check out, check in and delete files. But when they
select "Edit in Microsoft ---", they get a read only copy. What is wrong here? I
even went into the permissions for the document library and add in the specific
individuals and they still get the read only copy.



12 Answers Found

Answer #1    Answered By: Emily Clark     Answered On: Oct 12

What operating system and version of Office are the clients running? I've seen
this with older versions of either/both...

Answer #2    Answered By: Alycia Everett     Answered On: Oct 12

Windows XP and Office 2003..............

Answer #3    Answered By: Kaila Hahn     Answered On: Oct 12

A couple more questions:

1) Is the WebClient service running on the client machines?
2) Is there a firewall of any kind between between the server and clients?

Answer #4    Answered By: Ada Sosa     Answered On: Oct 12

1. Yes, the WebClient service is running.
2. This is an intranet so I'm not going through a firewall.

I have a total of 6 sites and this is the only one that is having this problem.

Answer #5    Answered By: Cheyenne Lewis     Answered On: Oct 12

running out of things I've seen before. If the client tries to save the
read-only copy  anyway from Office using Save As, is it successful?

Answer #6    Answered By: Liana Alston     Answered On: Oct 12

For a work around, the users  can do a save as to their local drive and then
upload it back into the portal.

Answer #7    Answered By: Daamodar Kolhe     Answered On: Oct 12

That's not what I was asking - even if the document  opens readon-only in Office,
you can normally save it back directly using File -> Save As. Does that work?

Answer #8    Answered By: Emerson Franks     Answered On: Oct 12

Oh sorry about that. When I click the Save As, it tries to save the file to my
local hard drive, not back to the original location (which is in the portal).

Answer #9    Answered By: Ned Storm     Answered On: Oct 12

But you should be able to use the Save As dialog to choose the original location
- what happens when you do so? Also, are you able to use FrontPage to edit
anything on the site?

Answer #10    Answered By: Myron Calhoun     Answered On: Oct 12

I have Admin rights so when I do a Save As, I can save it back to the original
location in the portal (by default, that's what shows up). But when the
Contributors do a Save As, they can only save to their local hard drive (by
default, their My Documents shows up). They do not have the option to save it
back to the original location in the portal.

Yes, I can use Frontpage to edit  the site.

Answer #11    Answered By: Rena William     Answered On: Oct 12

you say this is SPS - is the document  library in a WSS site  or an SPS
area? Is it possible there are unique permissions  applied at either the site,
area, or document library  level that you might have missed?

Answer #12    Answered By: Shanda Nolan     Answered On: Oct 12

The document  library is located in a WSS site. All the users  are contributors in
this site. For the document library, I left the default permissions  which are
the Reader, contributor  and Web Designer. I even tried adding individuals into
the permissions for the document library  and it still does not work. I added a
new user to the site  and everything works fine for him. I'm wondering if I have
to remove all the users and re-add them back in. What do you think?

Didn't find what you were looking for? Find more on Editing Documents Or get search suggestion and latest updates.