Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Document Library Gibberish

  Asked By: Jackie    Date: Jun 22    Category: Sharepoint    Views: 973

Has anyone encountered a situation (in WSS 3.0) where clicking on a
document in a doc lib returns gobbly-gook (this is the technical term
for a mix of errors and binary code)? I can pick out a few phrases on
the page like, "This program cannot be run in DOS mode," which occurs
at the beginning. The site returning this error is configured for
anonymous access, but I get the error whether I'm viewing the page
anonymously or signed in. I also have a site that isn't configured for
anonymous access, and documents from that site open fine. They both use
the same application pool. Ideas?

Share: 

 

13 Answers Found

 
Answer #1    Answered By: Sterling Allison     Answered On: Jun 22

Are you saying that all documents  return gobbly-gook? That is, if you
create a new Word document, upload it to the library  and then try to
view it you get the mix of errors  and binary code? Have you tried
creating another document  library in the bad site  and see if it behaves
the same bad way?

 
Answer #2    Answered By: Jessie Burton     Answered On: Jun 22

And Yes, it doesn't matter what kind of
document I upload: txt, jpg, whatever. Actually, it's odd that a .txt
document does it too, but it does. Here's a snippet of what's
returned:

This program  cannot be run  in DOS mode. $ö9²wWS²wWS²wWS•±,S°wWS%³)
S³wWS•±*SºwWSqxS³wWS•±:S¤wWS

And this is the same text regardless of the file type. I did create
another document  library on this site  and got the same result. I
thought that it might be an issue with IIS because execute
permissions were set to Scripts only. So, I changed it to Scripts and
executables (along the lines of this article
http://www.kbalertz.com/kb_894634.aspx). But that didn't change
anything so I set Execute permissions back to Scripts only.

 
Answer #3    Answered By: Kristopher Morales     Answered On: Jun 22

Crazy shot in the dark - did you do an iisreset?

 
Answer #4    Answered By: Marquis Ortega     Answered On: Jun 22

Actually, that's a good shot. I did do an iisreset -- several more
times than I actually needed to.

 
Answer #5    Answered By: Javier Hawkins     Answered On: Jun 22

Another shot in the dark: Does the web address for this particular
doc library  contain any illegal characters, or is it overly long
(+100 characters or more?)?

Illegal characters like @#$%&*, etc?

 
Answer #6    Answered By: Tracy Bass     Answered On: Jun 22

What if you copy the document  to a working document library  using something like
WebDAV? Does the document show correctly then? It may be time to migrate the
content to a new site.

 
Answer #7    Answered By: Dominick Blake     Answered On: Jun 22

Actually, the bad site  is an extension of a known good site. So the
documents from the bad site are already in the good site, and they
work fine  in the good site. In your opinion, should I kill the bad
site completely and start over by extending a new one?

 
Answer #8    Answered By: Randall Hunt     Answered On: Jun 22

I would definitely recommend expunging the bad site  and creating a new one if
you can.

 
Answer #9    Answered By: Joe Hart     Answered On: Jun 22

Okay. I'll try that and let you know what happens.

 
Answer #10    Answered By: Jorge Cole     Answered On: Jun 22

Well, that's exactly what I wound up doing. I expunged the whole site
from SP and IIS. I then extended my existing good site, removed all
existing doc  lib documents  and re-uploaded them. After all that,
things seem to work fine.

Have any of you experts seen a site  (or maybe just a document
library) go corrupt like that? At least, I assume that it was a
corruption. I can't think of what else it could have been. The doc
lib name/URL didn't contain any illegal, or otherwise suspect,
characters that might have caused SP's processing engine to choke.

 
Answer #11    Answered By: Rodolfo Tate     Answered On: Jun 22

I have seen this before. I assume it is content DB corruption.

Sometimes, stsadm.exe -o preparetomove will fix some stuff. You can always go to
your last backup and 'merge' content using stadm.exe -o export|import and limit
the overwrite of existing objects.

 
Answer #12    Answered By: Jesus Foster     Answered On: Jun 22

Fortunately, this was a very new
site, and I still had the documents  on my PC, so I didn't lose much.
But it is a bit disconcerting to know that content databases may
corrupt like that. I certainly hope that I don't see it again. But
should I, I'll keep the stsadm.exe stuff in mind.

 
Answer #13    Answered By: Alfredo May     Answered On: Jun 22

I saw things like that happen in WSS v2 but yours is the first WSS v3 problem
like that that I've heard about.

 
Didn't find what you were looking for? Find more on Document Library Gibberish Or get search suggestion and latest updates.

Related Topics:



Tagged:      

 

Related Post