Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Deserialize the custom Web Part

  Asked By: Tim    Date: Nov 23    Category: Sharepoint    Views: 758

I have a custom web part that is working ok on Test server but can not
be promoted to production server. When I pull in the DWP file into the
page, it gives this following error message in red.

"One of the properties of the Web Part has an incorrect format. Windows
SharePoint Services cannot deserialize the Web Part. Check the format of
the properties and try again."

I check the c:\windows\temp directory permission and my apppool user has
admin rights to the server box. I don't know where to turn?

Can someone guide me on what else to check next? I have deployed 3
other custom web parts and they are working fine. Just this latest one
is giving me issue.



3 Answers Found

Answer #1    Answered By: Tamika Cummings     Answered On: Nov 23

Did you find a solution to this issue?

I am having the same issue. My webpart was working, but now is not.

Answer #2    Answered By: Linsey Bauer     Answered On: Nov 23

It sounds as if the XML in the WSS v2 DWP file  or the WSS v3 webpart file is not
formatted properly. The two files use different formats.

Are you certain that you are using the same file in both environments?

Answer #3    Answered By: Ivy Salinas     Answered On: Nov 23

Are you by any chance using a custom  property editor or data type for the web
part property? If so, you need to deploy those items to production  just like
your development environment.

Didn't find what you were looking for? Find more on Deserialize the custom Web Part Or get search suggestion and latest updates.