MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Default.aspx in WSS2007

  Asked By: Keaton    Date: May 24    Category: MOSS    Views: 1723

I have a simple problem to discuss. My sharpoint site isn't
opening from a remote machine without explicitly typing default.aspx
(outside the LAN area). Even menu options are not opening
like "Actions", "Upload", "Help" etc etc. I did the same thing from
local pc and everything is working fine. Even I don't have to
specify default.aspx there. The "Scripts and Executable" permissions
are mentioned under the site settings for all the sites and
application pool settings looks to be fine. I am talking all this
with respect to WSS 2007 ie. V3.

I don't find any SharePoint related issue in this as the
behaviour has nothing to do with SharePoint. Let me be more clear,
then at least you can comment as to whether my assumption is correct
or wrong (and correct me if necessary).

Lets say, my machine name is 'rahul'. And the DNS alias
name is 'xyz'. So when I am accessing my site remotely using the DNS
alias name as http://xyz:port-no, I can't access the site without
mentioning default.aspx and even if I do, menu options and some
features are behaving erratically (javascript error, object expected
etc etc). Doing the same in local pc (using remote desktop), firstly
the authentication window is thrown twice, first one
showing "Connecting to xyz" and 2nd one showing "connecting to
rahul" (ie, machine name). After double authentication, page is
displayed as expected (default.aspx need not be mentioned as the
reference is made to the local system and menu options and other
features are behaving normally). The authentication window is thrown
twice even while trying to access using the IP address like
http://ip-address:port but rest all works fine locally. Whereas
directly accessing the site using the system name locally with
respective port like this http://rahul:port solves all problems -
that clearly concludes that there is nothing wrong in the settings
of SharePoint or IIS.

This is obvious by now, the problem is not SharePoint
related as I believe but must be with respect to the DNS settings
(network issue) or other network related issue. My query is how to
fix this, so that all users from anywhere on earth will be happy to
get the same feel of accessing the site as if from the local pc and
use it effectively?



2 Answers Found

Answer #1    Answered By: Jagdish Joshi     Answered On: May 24

You need to establish alternate access mappings from the Operations tab
in SharePoint Central Administration. WSS v3 doesn't like it when you
make changes directly in IIS.

Answer #2    Answered By: Christop Mcfadden     Answered On: May 24

This will happen if you're accessing WSS by a URL different than it is
expecting. Read through this and then make sure your URLs are correct,

Didn't find what you were looking for? Find more on Default.aspx in WSS2007 Or get search suggestion and latest updates.