Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Custom Workflow e-mail Links

  Asked By: Bryson    Date: Aug 06    Category: MOSS    Views: 1987

I'm creating a workflow in SharePoint designer that sends an e-mail.

I'd like to have the e-mail include a link so the user can open the
related SharePoint list item.

When I include the Encoded Absolute URL I get something like the
following:

http://sharepoint07.nsf.gov/oirm/dis/dmt/Lists/DesktopTasks/20_.000" target="_blank" rel="nofollow">sharepoint07.nsf.gov/.../20_.000

which goes to a Page Not Found error.

I can build the link using the following combination of text and fields:

http://sharepoint07.nsf.gov/[%DesktopTasks:Path%]/DispForm.aspx?ID=[%Des\
ktopTasks:ID%]

But this doesn't show up as a link if the message is viewed in Outlook
2003.

Am I missing something? Is something misconfigured that's producing the
bad URLs from Designer?

Share: 

 

2 Answers Found

 
Answer #1    Answered By: Richard Allen     Answered On: Aug 06

Try to copy the link  to the exact list  your going to look like this

<a href="https://sharepoint07.nsf.gov/list/nameoflist/DispForm.aspx?
ID=[ad ID here]">

 
Answer #2    Answered By: Ian Davis     Answered On: Aug 06

Try removing the brackets - /[%DesktopTasks: Path%]/ list  only the view
your linking to - / see below:

the top of my email body has the following: copy below in blue and add
your information:

<body><span style="font-family:'Bookman Old Style';font-size:Small";
style="color: #003399"><body>New Task Created:


<a href="Paste the url  here/DispForm.aspx?ID=[Add lookup to body current
item ID here]">

Press link  to Document - Click here: </b></a> </p></span></body>

when you paste the URL above you need to remove AllItems and replace
with /DispForm.aspx as above.

 
Didn't find what you were looking for? Find more on Custom Workflow e-mail Links Or get search suggestion and latest updates.




Tagged: