Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Custom fields not displayed in CQWP when accessed in anonymous mode

  Asked By: Erik    Date: Jul 21    Category: MOSS    Views: 1426

This is an unanswered old question:
In my MOSS 2007 site, I use a content query webpart in one of my pages.
The site can be reached both from intranet and internet with anonymous
access enabled. When authenticated from the intranet address everything
is fine. However when accessing with internet address (anonymous), this
webpart shows only 3 items which should show more than that. This is
not the case i always face, sometimes this webpart shows what it should
show. Do you have any idea on what causes this problem?

Share: 

 

2 Answers Found

 
Answer #1    Answered By: Brianna Olson     Answered On: Jul 21

Actually i didn't find an acceptable solution to tihs problem. But a
workaround may be to set an additional filter to the CQWP property page. Ýf
you set a filter like created date > 1/1/1900 -which contains all records
normally -, it will show all of the items.

 
Answer #2    Answered By: Selena Glenn     Answered On: Jul 21

From your answer i found my case is a bit different from yours, the
CQWP only shows the title column(or field), i have customize the
CQWP to display additional columns(or fields), direct access from
sharepoint designer is OK, all fields  are displayed, but when
accessed in anonymous, only the title column displayed, the items
are filted as my desired, no greater or less.

 




Tagged: