Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Custom event not firing

  Asked By: Lacy    Date: Jul 30    Category: Sharepoint    Views: 1141

My requirement was populating a custom list and sql database as soon as user
submits infopath form in form library

Hence i created assembly, inherited from IListEvent sink as mentioned in MSDN
and wrote custom code to populate the list
After generating the strong name i places it in GAC.Also the entry was made in
advanced settings which gave the name,version,poubli key token name in forms
library.

But the event is simply not firing .Any reason why the assembly is not getting
called ?
I am also not able to debug the code as i tried attaching it to w3p.exe .but
the assembly is never called.

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Jagdish Joshi     Answered On: Jul 30

Are you writing to the Event log? Try adding this in you code:

EventLog.WriteEntry("MyEvent Handler", "My code  got this far!",
EventLogEntryType.Information, listEvent.Type)

Also, are you using impersonation?

 
Answer #2    Answered By: Shara Johnson     Answered On: Jul 30

I am inpersonating ,but i think the assembly  itself is not getting called

Hence i wanted to know is there any other way out

 
Answer #3    Answered By: Victoria Bell     Answered On: Jul 30

Just Check whether windows object model event  handling is enabled or not , in
central administration page of wss.

 
Answer #4    Answered By: Cassidy Sharpe     Answered On: Jul 30

yes
Even the event  handling was checked in admin page .

Do we need to place the dll in gac  .That what i did .Can the dll be placed in
bin folder of root site.

 
Didn't find what you were looking for? Find more on Custom event not firing Or get search suggestion and latest updates.




Tagged: