MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Custom Edit Form not working

  Asked By: Brendan    Date: Nov 12    Category: MOSS    Views: 1361

Am trying to build a custom edit form for an existing custom list using

SPD help is quite clear & explicit on how to do this.

All goes well to build & save new form in a new aspx page. But when I go to
"properties" of the custom list to associate this new aspx page, the
"association" does not stick. I can do it, hit apply, hit OK, hit crtl-S.

Go to browser, it is not being used. Go back to SPD and the default edit form
is attached to custom list not my custom one.



3 Answers Found

Answer #1    Answered By: Benito Carey     Answered On: Nov 12

There's a dropdown in the properties association panel where you specify
which content type you will use the form  with. If your content type is
alphabetically after 'Folder' it will default  to Folder. Make sure you
pick your content type from the drop down or you are trying to apply
your custom  editing form to a "Folder". That won't work.

Answer #2    Answered By: Ebony Perkins     Answered On: Nov 12

I guess the content types mis-matched
before. Thanks.

Answer #3    Answered By: Anu K     Answered On: Nov 12

That's OK. I learned it the hard way when I was trying to demo that
feature in front of a live audience. I usually used announcements to do
it, but this time decided to use a Task list. I couldn't get it to
work. Of course five minutes after class was over I had one of those
"smack yourself in the forehead" moments and realized what had happened.
I won't make the mistake twice. But it's a real easy mistake to make.

Didn't find what you were looking for? Find more on Custom Edit Form not working Or get search suggestion and latest updates.