Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

What to do with a corrupt site?

  Asked By: Krista    Date: Mar 06    Category: Sharepoint    Views: 1501

It seems as if somehow one of the sites on my Sharepoint Portal Server
is corrupt.

I had moved the site over from an old server. I tested the site to
make sure it was working.

A few days later the site was no longer working. When I try to access
the site I get a 404 error message as if the site does not exist.

When I try to look at it in my backup tool, it errors out on the site.
It won't show me any other sites below this one in alphabetical order.

I just want to delete the corrupt site. I'm sure in my database there
are some references to this site and that is what is causing the
problem.

What is the best way to go about this?

If I need to delete the site directly from the DB how do you suggest
going about this?

Share: 

 

9 Answers Found

 
Answer #1    Answered By: Jennifer Jones     Answered On: Mar 06

I have a solution if you really want it, but it's not much fun.

 
Answer #2    Answered By: Annie Norris     Answered On: Mar 06

A few thoughts …

If it’s just one site  then … I’d try STSADM –o deletesite –url http://myserver/mysite

If it’s the entire server, it may be that the ISAPI filter got accidentally removed.

If it’s database corruption you may need PSS’ support to get the problem resolved.

I don’t recommend deleting directly from the database in a production environment.

 
Answer #3    Answered By: Chadd Hahn     Answered On: Mar 06

There's a neat little trick you can do if for some reason the site  is orphaned and it shows up in your database but the site isn't actually referenced anymore.

If that's the case, then you might want to check out this link:

www.gotdotnet.com/.../Workspace.aspx

 
Answer #4    Answered By: Cheryl Kelley     Answered On: Mar 06

I tried: STSADM -o deletesite -url http://myserver/mysite

And it said:

Cannot complete this action.
Please try again.

Thats one reason why I think I have some sort of corrupt  site. And it
is only one site, not the entire server.

 
Answer #5    Answered By: Sharonda Mcfarland     Answered On: Mar 06

Check out the note on the WSS Split. Yes, we realize that it's one site... it stinks, but it's a decent fix.

 
Answer #6    Answered By: Damon Garner     Answered On: Mar 06

Do you have permission to the database? Try doing this as the app pool account… Basically, I don’t use the STSADM command except with the app pool account because of interesting challenges…

If you try it as the app pool account and you still get the message it’s probably time to call product support.

 
Answer #7    Answered By: Christop Mcfadden     Answered On: Mar 06

Cannot complete this action typically means that there is an unhandled
error in the COM layer. While I don't recommend that you do anything
with the database, you may need to remove the offending row from the
Webs table in the content database. This certainly orphan rows in other
tables and will not be supported by Microsoft PSS.

 
Answer #8    Answered By: Victoria Bell     Answered On: Mar 06

I got engaged in another project.
And I don't really have much hope of figuring this one out!

I looked in my webs table and that site  is already removed from my
webs table.

If I was to do the database split, how does that work? Someone gave
me a link to:
www.gotdotnet.com/.../Workspace.aspx\
e4017e90bd

I'm really confused and frustrated here. I just rebuilt my sharepoint
server and moved  all the sites  over. Within a week I had this corrupt
site. Now I can't even backup anything on my server  because of this
corrupt site.

It was not my choice to install this software but now I'm stuck with it.

Yet how can I possibly do my job right if I can't even backup the damn
software?

 
Answer #9    Answered By: Cassidy Sharpe     Answered On: Mar 06

We recently went through an issue like this, we had a bunch of sites  down and we had two My Sites that got corrupted, and we couldn't do anything with them. We ended up trying this:

blogs.msdn.com/.../487365.aspx

We did get everything except the two My Sites fixed, and we tried deleting the rows in the content and config databases. It seemed not to work, but after about 30 minutes we tried navigating to it, and all of a sudden we got the 'Creating My Site' and we were back working  again.

Definitely not an easy thing to deal with, and we did notice that to be able to do some of these work arounds, you needed seperate content databases, which we didn't have. When we first rolled out, we didn't know any better. When we upgrade to SPS 3 we'll definitely be doing some more seperation of the content databases.

 
Didn't find what you were looking for? Find more on What to do with a corrupt site? Or get search suggestion and latest updates.




Tagged: