Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Content types

  Asked By: Jessie    Date: Sep 14    Category: Sharepoint    Views: 620

WSS V3 SQL 2000 I am site collection owner with full control rights

I have tried to mess with content types a couple of times and
apparently I am missing a vital piece of the puzzle.

I make a simple content type in the top site with an excel 2003 doc as
its base with a couple of metadata fields.

In a subsite directly below I can see that content type in the site
content types library. I create a library on this subsite and enable
content type management for it. Now when I choose new, there is
supposed to be a selection for content type. I never see this.

It has got to be something simple as this is a very basic function of
SharePoint. How frustrating I have not been able to get this to work

Can someone put me out of my misery? Is there somwthing in CA that I
need to do maybe? I love SharePoint, but sometimes I could punch it in
the face.



8 Answers Found

Answer #1    Answered By: Virendar Chaudhari     Answered On: Sep 14

Once you enable a library for management of content  types, in the library
settings management page you will see a new section for Content types. You need
to add the content types  you want to use in this library here. Once you have
done that, they will be available from the new menu of the library.

Answer #2    Answered By: Mitchel Villarreal     Answered On: Sep 14

It seems lile I had done that once, but I bet I was
in the wrong spot. Works perfect.

Answer #3    Answered By: Ranu Badhan     Answered On: Sep 14

I find you can't do a lookup on a sub-site column
in a content  type created a site above.

Answer #4    Answered By: Irene Moss     Answered On: Sep 14

I'm not sure just what you are trying to do. Could elaborate a little?

Answer #5    Answered By: John Scott     Answered On: Sep 14

you can using the cross-site lookup feature on codeplex. I do it all the time.

Answer #6    Answered By: Donald Torres     Answered On: Sep 14

I have had weak success with Codeplex things working on our
installation of SharePoint. Usually I see some weird error, notice
that others have also had the same problem by reading the comments
area, and see no resolution offered. But I am game to try things in
the test environment in any case. Many times it seems that SP1 breaks
stuff that worked before it was applied.

Has anyone else had good luck with codeplex bits for SharePoint? I
would love to hear about them.

How about problems?

Do any of you feel that there are some bits for SharePoint that seem
to work consistently as opposed to not?

Answer #7    Answered By: Courtney Scott     Answered On: Sep 14

You are enabling Content Type Management, but are you actually adding
the additional Content Type in the library settings? It's not that
"New" prompts you it's that once you add an additional Content Type to
the library you will get additional "New xxx" items in the drop down
list, one for each Content Type enabled in the library.

Answer #8    Answered By: Cecil Mckenzie     Answered On: Sep 14

Go to settings and document library settings. Scroll down a little
bit to the content  type section. Do you see the name of the content
type that you have created? If not then click the add from existing
site content types, select the one created. Back on the settings
page change the order so that is the 1st one displayed and try it

Didn't find what you were looking for? Find more on Content types Or get search suggestion and latest updates.