Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Content Type Error

  Asked By: Anila    Date: Mar 18    Category: Sharepoint    Views: 1055

I am getting the following error when trying to add a content type to a
Document Library.

"ERROR. One or more column references are not allowed, because the
columns are defined as a data type that is not supported in formulas."

I can create content types, no problem but when click add then ok to
add it I get the above error. I have tried creating a new library and
new content types but still no luck.



7 Answers Found

Answer #1    Answered By: Jack Carroll     Answered On: Mar 18

I assume you are using some custom column  in the content  type that is
calculated. Could you share the calculation formula. That may explain the

Answer #2    Answered By: Chandrabhan Agarkar     Answered On: Mar 18

No, no custom column  just create  a new doc lib. and create new
content type  and try to add  and you get the error. Is is possible
that someone made changes to the defaults and that is causing this

Answer #3    Answered By: Lonnie Cohen     Answered On: Mar 18

Did you add  any of the existing site columns to the new content  type? If so,
which columns? Some site columns, even existing ones might not be suitable for
use in a document library.

Answer #4    Answered By: Ruchir Satam     Answered On: Mar 18

I am not the person
that made any changes to create  this error. I am the support person
that has been tasked with trying to find out what the users have done
to create this error.

Prior to the users getting a hold of this instance of MOSS, adding a
Content type  to a Doc. Lib. worked fine. Then about a week ago they
called and said they are getting the error. When asked what they
changed of course they said nothing so it is now my job to try and
figure out what they have done and try and fix the issue.

So to answer your question I am not sure what they have done but I am
trying to figure out a way to resolve it. I will try and look at what
columns are associated with a newly created content  type and compare
that to an unmolested MOSS install to try and find out what they have

Is it possible for them to have changed a default feature so that
when you create a new doc. lib. and add  a plain old content type that
it maintains whatever change they have made?

Answer #5    Answered By: Suresh Chindarkar     Answered On: Mar 18

OK, try this first.

Go out and create  a custom content  type that inherits from the basic document
content type. Without making any more changes to that content type  see if you
can add  it to a document library. If that doesn't work take a look at the basic
document content type and compare the fields in it to a document content type
from a working SharePoint install.

Let me know what you find and we'll try something different from there to
resolve the issue.

Answer #6    Answered By: Varun Mehta     Answered On: Mar 18

That was it; I had to follow the trail all the way to the Parent
Document Type. There is where the users had made several changes from
the Default. So I removed the changes they made to the Parent Content
Type so there is no error  now. I can create  and add  new content  types
without issue again. My next step is to ask the user to not modify
the default Content types  but instead create new ones.

Answer #7    Answered By: Junior Jarvis     Answered On: Mar 18

Glad we were able to get to the bottom of the problem.

Didn't find what you were looking for? Find more on Content Type Error Or get search suggestion and latest updates.