MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Where is the Content Query webpart?

  Asked By: Tracie    Date: Mar 02    Category: MOSS    Views: 2619

I must be missing something here... I keep reading about all sorts of
neat uses for the Content Query webpart - but I can't find it! It's
not in the list of webparts when I try to add a webpart, and search
doesn't find it either. Is it only available on a certain sort of site
template? All our 2007 sites were created with a blank site template.



9 Answers Found

Answer #1    Answered By: Faith Delgado     Answered On: Mar 02

Its installed by default with MOSS 2007 (rather than WSS 3) - if you go
to add a web part its under the default section (you have to scroll down
a bit and you may have to expand the selection out.

Certainly its there on my implementation if I add a new site from within
the portal.

Answer #2    Answered By: Irving Hurley     Answered On: Mar 02

We've definitely installed MOSS 2007 -
but I wonder if we've gone about creating our sites the wrong way
or something. On the site in question, when I'm on the add web parts
screen, all I see under "All Web Parts" is the "Miscellaneous"
section with 8 web parts below. I also checked another one of our
sites. On this one, I have a lot more options - but under
the "Default" section you mention, only three web parts are
displayed: "I need to...", "RSS Viewer", and "This Week in
Pictures". No Content Query web part anywhere.

Answer #3    Answered By: Trevor Davis     Answered On: Mar 02

An update... I found this on a Microsoft help page:

"The Content Query Web Part is available only in sites that are
located on a server running Office SharePoint Server 2007. The
server administrator must make this Web Part available in the Web
Parts Gallery of the top-level site in the site collection. Also,
you must have authoring permissions for the top-level site in order
to open and edit page layouts."

I can't even find  it in the Web Parts Gallery, though. I did find
a "ContentByQueryWebPart.webpart" - which I didn't think was right,
but added it anyway. It wouldn't work once I added it to the page.

What am I doing wrong? Is there something I need to change in
Central Administration?

Answer #4    Answered By: Vinay Thakur     Answered On: Mar 02

It sounds like you have added the correct webpart. What is the error
you're getting when you add it to the page?

Also, what type of site are you adding this to? You cannot add it to
a MySite or you will receieve the following error:

Unable to display this Web Part. To troubleshoot the problem, open
this Web page in a Windows SharePoint Services-compatible HTML
editor such as Microsoft Office SharePoint Designer. If the problem
persists, contact your Web server administrator.

Answer #5    Answered By: Shayla Mcbride     Answered On: Mar 02

That's the exact error I'm getting, but I'm not on a MySite - this
is a top level site. I'm not convinced I have added the right web
part. It shows up under "Miscellaneous" as "ContentByQueryWebPart" -
almost like SharePoint doesn't really recognize it.

Answer #6    Answered By: Jarvis Rowe     Answered On: Mar 02

What about if you create a new team web site - that's what i did to
check for you.

Answer #7    Answered By: Selena Glenn     Answered On: Mar 02

I tried that too - still no Content Query web part.

Answer #8    Answered By: Christian Waters     Answered On: Mar 02

Your site web parts are inherited from the parent site. if you create your
site collection using the site 'Enterprise Collaboration' template -- under
'Publishing', then you sites (inherited from this site collection) will have
content type web parts.

Answer #9    Answered By: Virendar Bahudur     Answered On: Mar 02

Everyone else out there that has the
content query  web part - is this the template you used to create
your sites? Is it really only available through this template?

Didn't find what you were looking for? Find more on Where is the Content Query webpart? Or get search suggestion and latest updates.