Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Content Editor not saving changes

  Asked By: Cesar    Date: Jan 03    Category: Sharepoint    Views: 5823

I have an intermittent error occurring in many of my portals related specifically to the Content Editor web part.

What happens is a user tries to edit content in the content editor web part and receive an error JS alert stating “Cannot retrieve properties at this time.” When you click save, followed by “Cannot save your changes”.

I’ve done some research on in the MSKB, but none of the solutions are viable for me:

It says that when it has this with the content editor web part, it’s because it can’t load an assembly (I suspect we’d find that exact error in the event log as well). The reason it can’t is, according to the KB article, is that SharePoint can’t get enough info from IIS about the virtual server in question.

One remedy suggested is to change the site from using a specific IP to use (All Unassigned) IPs & implement host headers. Method 2 is not acceptable unless we have no other option as it really steps down in the security model.



4 Answers Found

Answer #1    Answered By: George Watson     Answered On: Jan 03

I had this problem and it took a while to track it down.

Eventually, I adjusted some IE options and it then worked properly again. I don’t remember the exact  options that I changed, but they must have been related  to security  issues. I had to relax the browser security a bit to get it to work again.

Answer #2    Answered By: Gabriel Patterson     Answered On: Jan 03

Please don’t take this as a “I don’t believe you”… just trying to resolve this…

I’m having a hard time  understanding why that would work. Because the content  editor web  part will break for a user, then that user  can come back in 10 minutes, 10 hours, or 10 days, and it will suddenly work. All the while, they are using the same PC and profile so their IE settings don’t change. It’s also intermittent  on which content editor  web part  throws the error.

I don’t see how this can be a client issue because when someone reports the issue, support  can duplicate it for a set period of time. Then suddenly, with no changes to the system, it fixes itself.

Answer #3    Answered By: Victor Hughes     Answered On: Jan 03

Perhaps your situation is different. I assumed it as a problem on the server, so I submitted a service request to them and listed the pages that I could update the content  on. They tried it and it worked, so I went to a different client system and it worked for me to. Then I started to adjust he IE settings and it all worked again. In my case, I was getting the error  with all content editor  web parts. However, I could edit  the text in FrontPage, when the IE edit wouldn’t work.

In summary, I had a problem, the hosting company couldn’t repeat it and when I adjusted my IE settings, the problem went away.

Answer #4    Answered By: Rashad Huff     Answered On: Jan 03

We were on a phone call with two members of the WSS product team last
week and they said that the single biggest PSS issue for SharePoint
today is people using a "specific IP address rather than All
Unassigned". They said that there are so many symptoms that result from
that configuration that they don't even have them all on one list. I
recommend and personally run all of my IIS Web Sites as "All Unassigned"
and rely on host  headers to process all requests to the appropriate Web

Do you have a situation where using "All Unassigned" for the IP address
is not possible? If you do, I'd be interested to understand your
specific situation better.

Bottom line, if you use a specific  IP address rather than All
Unassigned, expect irritating problems in many areas of SPPT. The WSS
team may be able to address this in a service pack.

Didn't find what you were looking for? Find more on Content Editor not saving changes Or get search suggestion and latest updates.