Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Contacts web part

  Asked By: Dominique    Date: Sep 02    Category: MOSS    Views: 1853

Does anyone use the Contact Details web part. Its behaviour seems very
strange to me and I suspect yet another bug in MOSS 2007.

I add the Contact Details web part to a site and then add a contact. I
specifically use the contact's username which is unique within Active
Directory and also within the SharePoint profile store. It seems to work
and some details about the contact are displayed. However, if I visit
another part of the site and then return to the site where I added the
Contact Details web part the picture displays as a brown rectangle. If I
click on the contact's name I am then presented with a list of all the
people with the same human name. It seems what is happening is that when
I supply a unique identifier, SharePoint is using that to find the human
name of the contact and then using the human name rather than the unique
identifier to find the person's details. If there is more than one
person with the same name (even though they have different usernames and
guids) then it can't display the correct contact's details. This is a
surprising way to do things and I suspect makes the Contact Details web
part almost useless except on the smallest sites. However, the even more
surprising thing is that if I refresh the page sufficiently often it
will occasionally work correctly.

Of course it could be that I am doing something completely wrong but
there doesn't seem to be that much I can configure that might solve this
one.

Share: 

 

No Answers Found. Be the First, To Post Answer.

 
Didn't find what you were looking for? Find more on Contacts web part Or get search suggestion and latest updates.




Tagged: