Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Constant login prompts

  Asked By: Guy    Date: Feb 02    Category: Sharepoint    Views: 2963

I'm sure this was asked before but I couldn't get a relevant hit
from SEARCH.

When entering a WSS site I'm asked for my login and passord (Windows
Authentication.) Any time I go to open a document, I'm prompted
again.

I also have multiple virtual servers on the same box and am pulling
logins from the local SAM on that box. Is there a way to store and
reuse the initial login credentials rather than contantly prompting
for credentials?

Share: 

 

15 Answers Found

 
Answer #1    Answered By: Bo Stafford     Answered On: Feb 02

I'm assuming that you are setup to use Basic Authentication - if so, then no
there is not a fix/workaround. The issue is that Basic auth is only good for
the program that does the authentication (the browser), once another program
(Office) tries to open  the document  it must authenticate seperately - there is
no way to share this. If you are setup in an intranet, using Windows Integrated
authentication instead will avoid both ptompts, but this cannot be used in
extranet/internet deployments as most firewalls do not support NTLM.

 
Answer #2    Answered By: Jocelyn Shelton     Answered On: Feb 02

Actually, no I'm set up for Windows Integrated Authentication. The
SQL server is set up for both Basic and Windows Authentication.
Could that be causing an issue?

 
Answer #3    Answered By: Joey Soto     Answered On: Feb 02

If you are using Windows Integrated you shouldn't be receiving any auth prompts
at all (in either the browser or Office) - unless the server is not local  or not
in your Trusted Sites list in IE.

 
Answer #4    Answered By: Gerard Randall     Answered On: Feb 02

Fed up of logging in for each new page or document?

Body:

If you add the site  (http://*.yourcompany.com
<http://*.yourcompany.com/> ) to the list of Trusted Sites within your
IE browser, then IE will use your workstation/Geniant Login information
(or will try to). Go to IE Tools/Internet Options. Click on the security
tab, then the sites "button". Add this as a trusted site:
http://*.yourcompany.com <http://*.geniant.com> .

Make sure the checkbox "Require Server Verification" is NOT checked!

Look at the bottom of the page to the right. It should ask you one more
time to enter account info and be sure to check the box  for Save
Password. Next time  you will not have to enter your username/password
everytime you try and hit the portal website.

 
Answer #5    Answered By: Audra Mccormick     Answered On: Feb 02

OK. I'll line up for the "Dope Slap". Didn't even think about
Trusted Sites.

 
Answer #6    Answered By: Christina Lewis     Answered On: Feb 02

We'll replace the 'dope slap' with a round of drinks for all if you don't
mind.

 
Answer #7    Answered By: Meaghan Webster     Answered On: Feb 02

I'll get in line right behind you, I didn't know either, but now I do..

 
Answer #8    Answered By: Sunny Delacruz     Answered On: Feb 02

Ok, you slapped-silly experts. Let's go on to the next problem before
any arms get broken. I'm running a SBS2003 domain/network. I have been
able to authenticate with no problem, using basic authentication, with
the site  in the trusted zone or the intranet zone. But, WSS will not
allow me to up-load a file to a document  library. I can do it to a WSS
site I have on www.xsolive.com <http://www.xsolive.com/> , but not on my
own site. The page that it wants to go to is
http://10.0.0.45/_vti_bin/shtml.dll/WSS100%20Course%20Library/Forms/Uplo
ad.aspx

And the error message I get is:

The page cannot be displayed


There is a problem with the page you are trying to reach and it cannot
be displayed.

________________________________

Please try the following:

* Click the Refresh button, or try again later.
* Open the Web site home page, and then look for links to the
information you want.
* If you believe you should be able to view this directory or
page, please contact the Web site administrator by using the e-mail
address or phone number listed on the Web site home page.

64 - Host not available
Internet Security and Acceleration Server

________________________________

Technical Information (for support personnel)

* Background:
The gateway has lost the connection with the Web site you are
trying to access.
* ISA Server: obts01.OutlookByTheSound.MukWoods
Via:

Time: 7/31/2004 1:15:37 AM GMT

Why can't WSS authenticate and save the file.

 
Answer #9    Answered By: .net Guru     Answered On: Feb 02

The error message indicates that there is an ISA server in the middle which is
having trouble contacting the server. Is http://10.0.0.45/ the normal URL that
you are making the other requests to?

 
Answer #10    Answered By: Renata Burt     Answered On: Feb 02

< Is http://10.0.0.45/ the normal URL that you are making the other
requests to?>
Yes, it is. I put the top-level site  there because if it didn't have a
site in the root, then there was something else I couldn't do--can't
remember right now. But I am in the site, looking at the update page.
I have selected the file to upload, and then click the save-and-close
button. So, how can it lose the host? Besides; ISA, the WSS, and the
SQL server are all on the one box. The file it is uploading is on a
separate is on the same box, also.
Drink looks pretty good about now.

 
Answer #11    Answered By: Lazaro Rutledge     Answered On: Feb 02

How big is the file, how much RAM does the server have, and what are the ISA
timeout settings? Might just be that the upload is either too big or taking too
long and and ISA is timing out.

 
Answer #12    Answered By: Karin Kerr     Answered On: Feb 02

Well, it gets more complicated. John West gave me a reference to the
following document:

"We have also made sample chapters of the SharePoint Resource guide
available here
www.microsoft.com/.../default.mspx

Chapter 6 covers the security architecture."

Chapter 6 says that a WSS site, by default, has minimum trust policy,
and as a result, has no file operation capabilities. To get the file
operation capability, you need to edit the web.config file (with
NotePad) to bump the trust level from Minimum to Medium. If gives an
address in \60\... file structure. However this has to be done before
the WSS site  is created. After creation, it has its own web.config file
in the root of its site. When I edited this file, it did the file
transfer to the temp file, and then checked out every possible
authentication, I guess because it took a long time, and then went back
to the upload page without including the files in the site. So, I think
it is something funny with the permissions that my site is not getting
right. Bummer.

With respect to the timing because of size, the files are small, and
copy up to the external site without problem. I am going to ask if she
made any other edits to her web.config file.

 
Answer #13    Answered By: Vinod Kumar     Answered On: Feb 02

This section is generally only applicable when creating your own custom code
(web parts, web services, asp.Net apps, etc) - have there been modifications to
the standard upload page that do things with the server file system? WSS out of
the box  would not require these type of permissions as it writes to the
database, not the filesystem.

 
Answer #14    Answered By: Jeffery Hayes     Answered On: Feb 02

That explains a lot, because I was sure they expected default
installations to be able to write pages. I am beginning to wonder if
the problem is that I have this in the root of the site. I'm going to
delete everything and start over again.

 
Answer #15    Answered By: Mohini Tiwari     Answered On: Feb 02

Installed SPS2003 on the Member Server, built a portal, and then a team
site. I can upload till the cows come home. I have no idea what I did
differently, but this construction works, and the first one didn't.

 
Didn't find what you were looking for? Find more on Constant login prompts Or get search suggestion and latest updates.




Tagged: