Logo 
Search:

Sharepoint 2010 Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint 2010       RSS Feeds

Configure Anonymous Access in SharePoint 2010

  Date: Sep 17    Category: Sharepoint 2010    Views: 2051

I have an issue with my Publishing Portal to access the site as Anonymous.
I follow all the steps in this link below and also i searched in the net and all
of them following the same.
community.bamboosolutions.com/.../sh\
arepoint-2010-cookbook-configuring-a-site-for-anonymous-access.aspx


Anyway, my problem is that whenever i try to access the site is still asking me
for the user name and password.

Share: 

 

15 Answers Found

 
Answer #1    Answered On: Sep 17    

You enable at the FARM but, you actually turn it on from the site collection.
Did you do that? What steps did you take?

 
Answer #2    Answered On: Sep 17    

i followed the same steps in this link below.
community.bamboosolutions.com/.../sh\
arepoint-2010-cookbook-configuring-a-site-for-anonymous-access.aspx


my steps was:
1- create the web app and enabled the anonymous access from the start.
2- create mu site collection as a publishing portal.
3- from the central admin i select my web app and then select the Authentication
Provider from the ribbon.
4- double check the Enable anonymous access is enabled.
5- I go back to the Web App Ribbon and select Anonymous Policy.
6- then i select all zones with none - no policy.
7- then i open my website at the top level of the site i open the site
permission.
8- I have access to an Anonymous Access button on the Ribbon.
9- i select the entire website in the Anonymous Access.

and that is it.

 
Answer #3    Answered On: Sep 17    

Any answer related this issue and how to solve it??

 
Answer #4    Answered On: Sep 17    

Worked for us, with one caviat. Once we enabled anonymous access for the
website, a form that did a A/D lookup for user info by username no longer
worked. We got an access denied error. We went back and disabled anonymous
access for the website and the lookup worked again.

The form with the lookup was in a different site collection from the site
collection that was given anonymous access. Sounds like a bug?

 
Answer #5    Answered On: Sep 17    

I did not mean to seem like I was dismissing your comments that you
followed the linked article. I just didn't have time to go and read it. I was
hoping maybe it was a simple issue of not enabling it in both spots as that was
the rookie mistake I made when I was first learning SP. And, just because you
say you followed the article having you put your own steps in writing may have
actually triggered an "a-ha" moment when you realize you actually missed a step.

At this point, I would make sure you don't have another policy or more
restrictive group stepping over the AA. Try from a different browser
maybe.....it sounds to me like it should be working. Is this a vanilla install?
Or, strip all permissions out and start from scratch.

 
Answer #6    Answered On: Sep 17    

This is a fresh install of SP 2010 In a Fresh Environment, and BTW there is no
other permissionpolicy defined in the system. also i have tried to open the site
from other browser and other machined and also from different version of browser
like IE, FF,...etc without any luck.

I just want to know to i need to do anything in the IIS or AD and security
rights in the server, what about also DB.

 
Answer #7    Answered On: Sep 17    

Its possible that the reason for the prompt has nothing to do with the
authentication setup.
Even if authentication is set up perfectly, you may get prompted because there
is a stylesheet or masterpage that isn't checked in.
I know that that the previous post mentions publishing, so if you are using
publishing features, then you may be changing masterpages, layout pages, css
files and images.
All of those items require check in and check out (unless you disabled that
functionality at the library level)
My guess is that something is still in a draft version and drafts cannot be seen
by anonymous users.
So check to see if all the elements are checked in and have proper permissions.

 
Answer #8    Answered On: Sep 17    

I feel this is really a good reason because i have my rest of the team working
in the same apps for development and they maybe left something without checked
in back.
BTW, is there is anyway to know what is still in draft or not checked in with
one shoot, because my apps is very big and i think its very difficult to go to
each place and check.

 
Answer #9    Answered On: Sep 17    

Well, start with the big things, check to see if the masterpages, layout pages,
css files and any images on the home page of your portal are checked out.

Another way to tell would be to create a plain jane team site, with NO
customizations..use the v4 masterpage and then set it to anonymous access in the
site settings.

If that works, then you know you set up AA correctly and now you just need to
track down the error.

 
Answer #10    Answered On: Sep 17    

Unfortunately, It didn't resolved and I am still diving in my servers to find
out..why?

Please, if you can tell me more info regarding this issue.

 
Answer #11    Answered On: Sep 17    

Just a question, do I need to enable the Guest user in the AD Domain, and is it
need it for the domain only or all the servers need to enable ?

 
Answer #12    Answered On: Sep 17    

Try disabling Single-Sing on

 
Answer #13    Answered On: Sep 17    

Are you talking about sharepoint single sign-on in sharepoint services, and if
this the one the fact that I'll be using this service later.

 
Answer #14    Answered On: Sep 17    

Yes i am speaking about the Sharepoint
Single-Signon service. Actually, for your case the service should be
enabled. NOT disabled.

 
Answer #15    Answered On: Sep 17    

But the service is already disabled in sharepoint. Also I need to tell that I'll
be using this service later time. So I don't think this is the solution.

Thanks Palani for your reply and answers and I appreciate that anyone can help
me to solve this.

 
Didn't find what you were looking for? Find more on Configure Anonymous Access in SharePoint 2010 Or get search suggestion and latest updates.




Tagged: