MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Changes to vs2008 web part does not show in moss ui

  Asked By: Neil    Date: Jul 27    Category: MOSS    Views: 1161


Pretty new to sharepoint. I just read an article by Pinal Dave which is the first time I've seen all the steps of creating a webpart using vs 2008 put together in one place. After being a .net programmer for years, finding specific information on sharepoint is not easy. Kudos to Pinal Dave!

What I've found is that there are other issues in webpart creation that are still elusive. I started out by following the article to the letter. The one variation in my technique was that I found that the sharepoint server I am using (which I didn't set up) had two wss "sites", one for port 80 and one for port 443. Not sure what to do I moved my webpart dll to the 443 bin directory.

Strangely, I followed the rest of the article and had the great experience of seeing my "hello world" web part show up in the home page of the site collection (the article has you create a label with "Hello World" as text and the label is added to the controls collection.)

Feeling happy, I started to work on modifying the web part to show some additional information instead of the original "hello world" message; it wasn't a big change. What I found was that though I moved the webpart dll to the same 443 bin directory, I saw no change in the web part in the ui. I tried a few things such as running issreset, removing the webpart from the gallery and then readding it, closing and reopening the browser, etc. Nothing seemed to work.

I let the issue go and opened the site a few days later. Oddly I found the small change I'd made to the webpart a few days before was there. I've tried to change the webpart a couple of more times by adding new labels and adding them to the control collection in the CreateChildControls procedure. There was no immediate change in the web part in the ui. I figured that continuing to repeat these experiments would be useless.

I'm sure there is something small I'm missing. Any advice would be appreciated.




No Answers Found. Be the First, To Post Answer.

Didn't find what you were looking for? Find more on Changes to vs2008 web part does not show in moss ui Or get search suggestion and latest updates.