Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Changed SiteLogo creates problem for the users

  Asked By: Josiah    Date: May 21    Category: Sharepoint    Views: 1258

The thing I cannot figure out is, I
have a custom logo on the sharepoint portal site. That I created and
copied it in the same folder where the default logo is i.e.
/_layouts/images/sitelogo.gif

The way I changed pointers to the site logo is
Site Settings -> Change Portal Site properties and Site creation
settings
Under Custom Portal Site Logo, I replaced the contents of "Location of
logo file:" with /_layouts/images/newsitelogo.gif

The logo comes up fine when I log in on the Portal Site. However when
the user logs on to the site, the site displays however while trying to
bring
up the logo it prompts the user to put in ID & PWD. The user puts in the
ID & PWD,which I think fails since the logo does not get displayed.

It looks like it is a permission problem, but how do I solve this???

Share: 

 

6 Answers Found

 
Answer #1    Answered By: Angel Jordan     Answered On: May 21

From IIS go to _layouts/images/(img name) and check
the enable anonymous access.

 
Answer #2    Answered By: Darrell Peters     Answered On: May 21

Just curious... Why do I need to allow anonymous access. The default
sitelogo.gif has windows authentication enabled and not anonymous
access.

 
Answer #3    Answered By: Lester Casey     Answered On: May 21

How did you access this folder   /_layouts/images?
I need to go to the IIS manager and drill down to the default  website to finde the _layouts web etc.
Could it be that you are actually putting the image file  in a _layouts/images folder under your local Inetpub/wwwroot ?
Maybe that is why it can find the image to load on the page when you try it and not when others are trying it.

 
Answer #4    Answered By: Rudy Francis     Answered On: May 21

The way I accomplished the task is as under:

Copied the .gif file  to the location  /_layouts/images in which I found the sitelogo.gif file (SharePoint's default logo  file)
Went into IIS Manager, selected Web Sites, CompanySite (I did not use the default  web site, but I guess that does not matter) -> _layouts -> images and I found the gif file that I had inserted

Is this the correct approach, can you add a gif file directly in IIS Manager in the _layouts/images folder  ???

 
Answer #5    Answered By: James Miller     Answered On: May 21

The only file  that physically exist in webroot is web.config. Rest are the
pointers to other resources.

/_layout is actually mapped to C:\Program Files\Common Files\Microsoft
Shared\Web Server Extensions\60\template\

In tha mapped directory you will find the images directory you will find the
images directory as well. That's where you should put  the image files.

I am not sure what you mean by directly inserting a file in IIS. You can
directly update/replace a file using FP2003 which actually updates/replace
the file in C:\Program Files\Common Files\Microsoft Shared\Web Server
Extensions\60\template\images.

 
Answer #6    Answered By: Collin Griffith     Answered On: May 21

I had this problem  also, but figured the solution. I am not sure
why, but when I put  the new logo  file in the same folder, I
neglected to check the NTFS permissions, and I had not altered one
of the original pictures (therefore it did not have the same
permissions).

Needless to say, I got the exact same problem. If you compare the
permissions on your new file  with others, I believe you will find
they do not match. If you change  the permissions to match, it should
work fine.

I did not enable anonymous, though it seems that might work. My
customer is pretty picky about security.

 
Didn't find what you were looking for? Find more on Changed SiteLogo creates problem for the users Or get search suggestion and latest updates.




Tagged: