Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Category Issue

  Asked By: Code    Date: Sep 14    Category: Sharepoint    Views: 789

Categories are working great for me for the most part but I am having
one problem.

After adding a document to a Category and it showing properly, we have
decided to remove it from the list. However, although I edit the profile
and remove the check for the category, it still shows up. I have tried
checking the document out, checking it in and still no luck. Although the
profile shows nothing for a category choice, the document still shows up
under the category web part.

Share: 

 

8 Answers Found

 
Answer #1    Answered By: Hailey Clark     Answered On: Sep 14

I think the problem  is not with the profile but with the index which
has been created when you had assigned it some category. I think you
need to remove  the index for that document.
A workaround could be to purge all indexes and perform a "full build"
for the indexes.
Try this and then try searching for that document.

Post your results. i am also keen to know.

 
Answer #2    Answered By: Nisarg Shahane     Answered On: Sep 14

How do I re-index the site? I looked into that yesterday. I went into the
SPS admin program and reviewed the services but could not figure it out.

 
Answer #3    Answered By: Naimish Misra     Answered On: Sep 14

I dont have SPS on my machine right now. but as far as i can recall,
in the SPS admin, do the follo.
1. right click on the workspace in which you have that "document".
2. In the "All tasks" there is one option to purge all indexes.
3. Select that option.
4. After doing that again go to "All tasks" and click on "Full
incremental Build"

 
Answer #4    Answered By: Terence Thornton     Answered On: Sep 14

It did not work.

I reset the index and did the full increment, but the old document  still
showed up. When I come back from lunch I am going to delete the category
and reassign the documents.

I hate to do that but better now than once the site becomes larger.

I will keep everyone up to date.

 
Answer #5    Answered By: Alka Sarabhai     Answered On: Sep 14

try this before you delete the category.
I think since the category  is trained it will auto categorize that
document even if you do not specify any category.

try the following and let us know the results.

1. Copy that doument to some place outside the workspace.
2. Now delete that "document" from the workspace.
3. perform the "reset index" and "full incremental build".
4. After the index is built, copy the document  in the workspace.
5. In the profile of that document, remove  the "catgeorize
automatically " ( idont remeber the exact line ) option.
6. Now check  in the document without assigning any category.
7. now try the search and see whether it works

 
Answer #6    Answered By: Eashan Nadkarni     Answered On: Sep 14

Sorry but I read your post after I had deleted the category. That
solution worked Great.

 
Answer #7    Answered By: William Odom     Answered On: Sep 14

Even I had the same problem. I removed all categories  and still could see
them in the categories property of the document. Here is how you (that's how
I solved) can solve the problem.

1. Download the categoty sort tool from Microsoft tool. This code will be
starting point.
2. In place of the call to subroutine call to sort, you can reset each of
the entry in the category  array to blanks.
3. Now you'll have cleam categories
4. Recreate the categories using a script (I guess I got this code from
sharepointcode)
5. That's it!. In fact I didn't have amny documents, so I could
re-categorize. If you already have large numbers, this may not be a good
option.

 
Answer #8    Answered By: Mia Scott     Answered On: Sep 14

Sorry for giving the wrong file name.The file that needs to be changed
is "TahoeUtils.asp" and not EditProfile.asp

 
Didn't find what you were looking for? Find more on Category Issue Or get search suggestion and latest updates.




Tagged: