Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Beta 2 TR Search issues

  Asked By: Grace    Date: Jul 07    Category: Sharepoint    Views: 795

I installed the Beta 2 TR on a new test environment we just set up
using the slip stream approach. Everything appeared to have installed
correctly but when it comes time to turn on search it errored out
with the only error message being SPSearch when trying to turn on WSS
search and OSearch when turning on Office SharePoint Server search.
When I checked the services both were not running so I started the
services and got an error that says Office SharePoint Server Search on
local computer Error 6: The handle is invalid. When I looked at both
accounts they were running off of an NT Authority\Local Service
account if you change the log on as local system account or change
that NT Authority account to a local admin on the box you can start
the service . After that if you try to start the search service
through the UI you get the message AN Unhandled exception occurred in
the user interface.exception Information: OSearch. Any idea on what I
need to do in order to make search work?

Share: 

 

3 Answers Found

 
Answer #1    Answered By: Cassidy Sharpe     Answered On: Jul 07

I also saw this same error  after installing my second TR (the first didn’t do that). I was unable to get the search  working so I created a new web application & new SSP and made the new SSP the default for my primary web site. The search worked after this.

installed  the Beta 2 TR on a new test  environment we just set  up
using the slip stream approach. Everything appeared to have installed
correctly but when it comes time  to turn  on search it errored out
with the only error message  being SPSearch when trying to turn on WSS
search and OSearch when turning  on Office sharepoint  Server search.
When I checked  the services  both were not running  so I started  the
services and got an error that says Office SharePoint Server Search on
local computer  Error 6: The handle  is invalid. When I looked at both
accounts they were running off of an NT Authority\Local service  
account if you change  the log  on as local  system account  or change
that NT Authority account to a local admin  on the box  you can start  
the service . After that if you try to start the search service
through the UI you get the message AN Unhandled exception  occurred in
the user  interface.exception Information: OSearch. Any idea  on what I
need to do in order  to make search work?

 
Answer #2    Answered By: Peter Peterson     Answered On: Jul 07

I thought in order  to create a SSP you needed to be able to set  an indexer, and the only way to setup an indexer was to turn  on the search  service through assign services  to servers? Am I mistaken about this?

 
Answer #3    Answered By: Hans Weiss     Answered On: Jul 07

Since Search is major component of an SSP, some member of the farm has to be an index server  so you can configure the indexer when you create an SSP. If you are building a farm, these services  need to be a domain account.

 
Didn't find what you were looking for? Find more on Beta 2 TR Search issues Or get search suggestion and latest updates.




Tagged: