Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

BackupExec 10.0 with a SharePoint agent.

  Asked By: Stacey    Date: Nov 03    Category: MOSS    Views: 1359

We have a SharePoint Portal Server 2003 production environment and would

like to copy this environment over to our test environment for test upgrades

to MOSS 2007. I've been using the SharePoint Portal Server 2003 Backup and

Restore tool just as a supplementary solution along with BackupExec 10.0 with

a SharePoint agent. My guess is that it's just to use the Backup and Restore

tool on our prod env. and then do a restore with these files on our test env.

The thing is, we recently upgraded our backend from SQL Server 2000 to SQL

Server 2005, and now the Backup and Restore tool fails to backup the SITEDBS

but succeeds in backing up the INDEX.

Here's the output from the backup logfile:



12/06/06 12:52:06:547 UNK 00000000 00001A68 BackupApplication now in

progress: Restore=False, Server=%SharePointServer%,

AppName=03186cf4-b34a-4af7-8970-ffdd294fa3b9,

Path=\\%SQLServer%\BACKUP\Backup_des_2006\Backup_061206_2\Backup_061206_2-%DBName%_SERV-%SharePointServer%.SPB

12/06/06 12:55:26:625 UNK 00000000 00001A68 BackupApplication Thread setting

its status to completed and exiting

12/06/06 12:55:26:688 UNK 00000000 00001B48 SearchFarmConfig: CTOR: setting

the culture info 'English (United States)'

12/06/06 12:55:26:797 UNK 00000000 000019A4 BackupSQL now in progress:

Restore=False, Server=%SQLServer%, Database=%DBName%_SITE,

Path=\\%SQLServer%\BACKUP\Backup_des_2006\Backup_061206_2\Backup_061206_2-%SQLServer%-%DBName%_SITE.SPB

12/06/06 12:55:26:813 CRI 00000000 000019A4 SQL Backup called with

Server=%SQLServer%, Database=%DBName%_SITE,

BackupPath=[\\%SQLServer%\BACKUP\Backup_des_2006\Backup_061206_2\Backup_061206_2-%SQLServer%-%DBName%_SITE.SPB], Percent=5

12/06/06 12:55:26:953 CRI 00000000 000019A4 Connecting to SQL Server

%SQLServer% ...

12/06/06 12:55:27:078 CRI 00000000 000019A4 Connected to SQL Server

%SQLServer%

12/06/06 12:55:27:078 CRI 00000000 000019A4 Connected To Server

12/06/06 12:55:27:172 CRI 80040C81 000019A4 Failed to back up the database.

12/06/06 12:55:27:172 CRI 80040C81 000019A4 Leaving SQL Backup

12/06/06 12:55:27:172 UNK 00000000 000019A4 [Microsoft][ODBC SQL Server

Driver][SQL Server]Cannot open backup device

'\\%SQLServer%\BACKUP\Backup_des_2006\Backup_061206_2\Backup_061206_2-%SQLServer%-%DBName%_SITE.SPB'.

Operating system error 5(Access is denied.). [Microsoft][ODBC SQL Server

Driver][SQL Server]BACKUP DATABASE is terminating abnormally.

12/06/06 12:55:27:188 UNK 00000000 000019A4 [Microsoft][ODBC SQL Server

Driver][SQL Server]Cannot open backup device

'\\%SQLServer%\BACKUP\Backup_des_2006\Backup_061206_2\Backup_061206_2-%SQLServer%-%DBName%_SITE.SPB'.

Operating system error 5(Access is denied.). [Microsoft][ODBC SQL Server

Driver][SQL Server]BACKUP DATABASE is terminating abnormally.

12/06/06 12:55:27:203 UNK 00000000 000019A4 Exception in BackupSQL:

Source=SQLBkMgd, Message=The operation failed on server %SQLServer%. For more

information, see the Microsoft Windows Event Log on that server.

To me it sort of looks like there are some permissions that might be wrong.

Are there additional permissions needed once the server has been updated to

SQL 2005?

I have, btw, installed the Client Connectivity tools on the SharePoint

server from the SQL 2005 CD.

Any ideas?

Share: 

 

3 Answers Found

 
Answer #1    Answered By: Linda Mason     Answered On: Nov 03

Did you run the stsadm.exe after upgrading? I think you need to do this. Also, you need to ensure that you are running service pack 2 on sharepoint  or you won't be able to run SQL 2005 either. I did not see anything that talked about upgrading existing content from SQL 2000 to 2005, only stuff about new installations using 2005 but I am sure its out there. Here is a link to MS articles

http://support.microsoft.com/kb/917446

 
Answer #2    Answered By: Hans Weiss     Answered On: Nov 03

Have you installed the sql 2005 tools on your front end web server  ? you need these installed or it wont do the backup

 
Answer #3    Answered By: Alison West     Answered On: Nov 03

I did install the SQL 2005 client connectivity tools on our front end. However, I do believe I did it and hoped it would upgrade the existing SQL 2000 client tools. So after the install of the ’05 tools I ran an uninstall of the 2000 tools and I’ve also installed the ’05 tools again. But I keep getting the error.

I found a blog out there describing a quite similar issue:

http://guru-web.blogspot.com/2006_05_01_archive.html

 
Didn't find what you were looking for? Find more on BackupExec 10.0 with a SharePoint agent. Or get search suggestion and latest updates.

Related Topics:



Tagged:        

 
 
 
 

Related Post