Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Back up a Web application by using the Stsadm error

  Asked By: Krista    Date: May 04    Category: Sharepoint    Views: 2791

From the below link i got the syntax of backup web application

technet.microsoft.com/en-us/library/cc288541.aspx

stsadm -o backup -directory <\\server name\folder name> -backupmethod full -item
<Web application name>


and when i try to backup a web application, its not accepting the command. I m
sure in not using the correct web application name. I got the web application
name using stsadm -o backup -showtree

stsadm -o backup -directory f:\backup -backupmethod full -item Windows
SharePoint Services Web Application\SharePoint-80

I m using "Windows SharePoint Services Web Application\SharePoint-80" as web
application name.

Any Idea what should i write to make this work?

Share: 

 

8 Answers Found

 
Answer #1    Answered By: Emily Clark     Answered On: May 04

Try either "Windows SharePoint Services Web Application" or
"SharePoint-80". The backslash is a division between two items, so it's
getting confused. Myself, I just do "farm" and grab the whole thing.

 
Answer #2    Answered By: Alycia Everett     Answered On: May 04

you are right "Farm" is working in web  application name but Windows SharePoint
Services Web Applicaion and Sharepoint-80 is not working.

Does any have idea  why its not working?

stsadm -o backup  f:\backup -backupmethod full  -item Farm
( Working)
stsadm -o backup f:\backup -backupmethod full -item  SharePoint-80 (
Not Working)
stsadm -o backup f:\backup -backupmethod full -item Windows SharePoint Services
Web application  ( Not Working)

 
Answer #3    Answered By: Kaila Hahn     Answered On: May 04

In your stsadm  command

stsadm -o backup  -directory f:\backup -backupmethod full  -item Windows
SharePoint Services web  Application\ SharePoint- 80,

be sure to put quotes around the web application, since it includes spaces.

stsadm -o backup -directory  f:\backup -backupmethod full -item  "Windows
SharePoint Services Web Application\SharePoint-80"

 
Answer #4    Answered By: Ada Sosa     Answered On: May 04

I m near to get Sharepoint-80 web  application backup  Please check

Item "Windows sharepoint  Services Web Application" with quotes is working fine

when I used Item "Windows SharePoint Services Web Application\ SharePoint- 80"
is display message that Item "Windows SharePoint Services Web Application\
SharePoint- 80" not found.

Only Item "SharePoint- 80" is also
display message that Item "SharePoint- 80" not found.

stsadm -o backup -directory  f:\backup -backupmethod full  -item "Windows
SharePoint Services Web Application\ SharePoint- 80"
and
stsadm -o backup -directory f:\backup -backupmethod full -item  "SharePoint- 80"

both not working

"stsadm -o backup -showtree" display this information
Farm\
[SharePoint_Config_190a3cec-7510-46fa-8f43-4551c370df75]\
Windows SharePoint Service Web Application\
SharePoint - 80\
Wss_content\
[WSS_Administration]\
etc.

 
Answer #5    Answered By: Cheyenne Lewis     Answered On: May 04

You have to many spaces, as far as I can tell. There is no space between the
dash and the 80. Also, there is no space after the \. "Windows SharePoint
Services Web Application\SharePoint-80"

Remember, we are simply going off of the information you are providing us.
We are not seeing what you are on the screen.

 
Answer #6    Answered By: Liana Alston     Answered On: May 04

Here's what my showtree looks like:


Farm\

[WSSConfigDBv3]\

Windows sharepoint  Services Web Application\

Default Web Site\

WSSContentDB_www\

toddklindt.com -80\

WSS_Content_tk-com\

[WSS_Administration]\

[Web Application]\

WSS_AdminContent_19d5f8dcd99048ccb275fffb22add337\

Windows SharePoint Services Search\

[Search instance]\

[WSS_Search_BLAH]\



The following command  works for me:

stsadm -o backup  -directory \\server\backups -backupmethod full  -item
"Default Web Site"



This works too:

C:\>stsadm -o backup -directory  \\server\backups -backupmethod full
-item "xyz.com -80"

Not sure why it's failing for you.

 
Answer #7    Answered By: Daamodar Kolhe     Answered On: May 04

Its working when i used with space "SharePoint - 80".

I was not giving space after SharePoint and before 80.

 
Answer #8    Answered By: Emerson Franks     Answered On: May 04

If you turn "Quick Edit" on for your command  prompt you can use your
mouse to copy and paste stuff. That's what I normally do to make sure
I'm typing the correct  thing.

 
Didn't find what you were looking for? Find more on Back up a Web application by using the Stsadm error Or get search suggestion and latest updates.




Tagged: