Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Authentication failed because the remote party has closed the transp

  Asked By: Ladonna    Date: May 31    Category: Sharepoint    Views: 2509

We're getting this error while trying to create rules for a new
search scope, set at the site level. We found a solution to a similar
problem, trying to access search settings for the SSP, which involves
using selfssl from the IIS Resource Kit:

"My team was experiencing the same issue when attempting to access
the search settings screen in our environment. The search settings
page communicates with the index server using the SearchAdmin.asmx
web service on the index server, and it does so over SSL. In our
case, the SSL certificate that SharePoint assigned to the web site
during installation had a problem, which caused us to see
the "Authentication failed because the remote party has closed the
transport stream" message anytime we accessed the search setttings
screen. The following steps resolved the issue for us:

1. Install the IIS 6.0 Resource Kit on the index server
2. Assign a new SSL certificate to the Office SharePoint Server Web
Services site on the index server using the selfssl tool from the
resource kit.

selfssl.exe /N:CN=<name of index server> /K:1024 /V:<number of days
cert should be valid> /S:951338967 /P:56738

The /S and /P parameters specify the web site ID and port number,
respectively, of the Office SharePoint Server Web Services site in
IIS. They should be set to the appropriate values for your

After assigning a new cert, the search settings page worked for us."

We're using CA authority for our certificates, not selfssl. Has
anyone had this problem and solved it?



1 Answer Found

Answer #1    Answered By: Akshara Negalur     Answered On: May 31

Yes, I have seen this problem  in the last couple of weeks, in the
course of building a farm in a VM environment. Another symptom was
that, on the very first attempt to communicate, the server  hosting
the web service  reported this error  in the system event log:

Event Type: Error
Event Source: Schannel
Event Category: None
Event ID: 36871
Date: 11/7/2008
Time: 5:15:24 AM
User: N/A
Computer: GOVIRAPP11
A fatal error occurred while creating an SSL server credential.

found  that there was some kind of certificate  already assigned  to
the site  in IIS. I removed that certificate and assigned a
production one that we use for another site, and that fixed the
issue (even though the certificate I assigned did not match the site
name of the web  services site).

Looking at our production environment, the web services site seems
to have no assigned certificate, but it works without any issue, so
maybe I could have just removed the certificate that had been
assigned during the installation. The other strange thing is that
our SSP is set  up with the option to use SSL turned off, so I don't
understand why it is doing so.

For the moment, I have documented in our farm installation
instructions to assign  a certificate (as I did) to the web services
site on all index  and query servers.