Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Another generic error

  Asked By: Carolyn    Date: Apr 01    Category: Sharepoint    Views: 693

I am getting an error now when trying to view a list item. Not sure when it really started but there has not been any development / changes to the system in a while.

So, when viewing an item at portalname/txtlstvw.aps?LstID=<somelistid> I get this error:

Error: Object reference not set to an instance of an object.

I know the listing is there - added several listings, approved them, and they appear in the New for You Web part but error out when trying to view them. I can edit the listing when viewing from the source (the place where I added it) but cannot view it from anywhere else. The listing is simple text that I added through the Add listing form.

Any ideas? All suggestions are appreciated.

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Sharonda Mcfarland     Answered On: Apr 01

Another thing - it only errors when viewing  a text  listing. Viewing a listing  for a site or a document works as always .... not sure what the difference is except that it's passing the LstID parameter instead of redirecting to a site, or opening a document.

 
Answer #2    Answered By: Harshini Raju     Answered On: Apr 01

What kind of a page is txtlstvw.aps? What kind of Web Part is trying to
display the listitem? Can you display it from another Web Part page or a
new list  view?

 
Answer #3    Answered By: Christop Mcfadden     Answered On: Apr 01

It's the page for viewing  a listing. Typo; should be txtlstvw.aspx?LstID<somelistID>

I copied the file from another server and it fixed t he problem. I kept the old file for comparison to see if I could tell what happened and I'll do that as soon as I get a chance - I'll post if I find the culprit.

 
Answer #4    Answered By: Gopal Jamakhandi     Answered On: Apr 01

There are two controls that were commented out on the file. They are
<SPSWC:LocString runat="server" id="LargeHeading" />
and
<SPSWC:BreadCrumbTrail runat="server" id="BreadCrumbTrail" TitleLocId=MultiPage_BreadcrumbWebPartTitle LeadInTextLocId="SiteForm_BreadCrumbTrail_LeadIn_Text" VerticalMode = "true" FrameType="None" />

I assumed that they could be removed from the file (since they are commented out and not being rendered) but when I do, I get the error. Any ideas  on why? It's not a huge deal now that I know "what" causes the problem, just wondering about the why ...

 
Didn't find what you were looking for? Find more on Another generic error Or get search suggestion and latest updates.




Tagged: