Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Anonymous access WSS fails

  Asked By: Quintin    Date: Nov 23    Category: Sharepoint    Views: 1078

I'm probably overlooking something to get it to work
well: I need to set up a WSS site with a couple of
customized webparts for anonymous users.

A couple of settings:

- On this server, SPS is also installed
- In IIS I enabled Anonymous access for IUSR_myServer
- I create with Administrator account a WSS site and
dragged a webpart on it
- Under Site Settings, I added this user IUSR_myServer
- At the highest level, I did the same
- Under Anonymous access, can access Entire Web Site
- Allow all Authenticated user to access site, as

Now when I save the site as favorite, close the
Browsers, reset IIS, open browser again, I'm still
prompted with a popup. Earlier I could see the page
but my personally build webpart was not visible, only
the Login button in the right top corner.

What am I doing wrong or forgetting?



2 Answers Found

Answer #1    Answered By: Agustin Miranda     Answered On: Nov 23

do you see


in your manage users/permissions page?

Answer #2    Answered By: Arron Middleton     Answered On: Nov 23

Wished it was that simple, on the WSS site  it did, on
the SPS site I added  this user  group but it did not
have any effect.

In the meantime I removed the 2 webparts  from the page
and now the page loads without problems and ofcourse
without the 2 webparts. Now in the top  right corner I
see the Login button  but I would have like the 2
webparts on the page also.

So... do custom webparts not allow anonymous  access
and how can I disable that. I've put the webpart  in
debug mode but it won't even start running before the
popup already appears.

In FrontPage I looked into the webpart properties but
there no .DWP property either set  it anonymous.

I keep on digging... in the meantime any help is

Didn't find what you were looking for? Find more on Anonymous access WSS fails Or get search suggestion and latest updates.