Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Alter URL from "http://servername/default.aspx" to "http://wss.companyname.com"

  Asked By: Karen    Date: Nov 06    Category: Sharepoint    Views: 5254

I already posted this questions to the group. But still I've the
same problem. Please help
I installed WSS 3.0 beta 2(NOT beta TR)in vm machine and I
configured it. But in order to access it, I'm
using "http://servername/default.aspx". But I need a URL
like "http://wss.companyname.com". I tried Alternate Access Mapping
it didn't work. This is what I did to map it:
1. I went to Central Administration page -> Operations -> Global
Configuration Section -> Alternate Access Mapping. Here I
clicked "Show
all" and then "sharepoint(80)". After that I clicked "edit outbound
URL" and then I typed "http://companyname.com" target="_blank" rel="nofollow">http://companyname.com" under extranet and
intranet and then I saved it. After doing this I closed the admin
and then open a new window and there I typed "http://companyname.com" target="_blank" rel="nofollow">http://companyname.com"
but it showed "Page cannot be displayed". I checked all the browser
settings and checked the all resources from the internet for access
mapping , but everything say the same.



6 Answers Found

Answer #1    Answered By: Delbert Frederick     Answered On: Nov 06

Did you add the host header to the IIS Web Site?

The web site must register the Host Header with HTTP listener on operating system so that requests for that URL are forwarded to the appropriate site.

If it is not registered, then the requests are forwarded to the default web site.

Answer #2    Answered By: Kalyan Pujari     Answered On: Nov 06

if you don't mind, can you please add the host header and creating
alternate access  mapping in step-by-step format.

Answer #3    Answered By: Allison Stewart     Answered On: Nov 06

1. Open IIS Manager
2. Expand the Web Sites folder
3. Find the virtual server that is hosting your site. Right click on
it and select Properties
4. Make sure the Web Site tab is selected.
5. Click on the Advanced button next to the IP Address field.
6. Select the first item in the "Multiple identities for this Web
site" field. This should have the IP address assigned to the site
and the port it is using. The IP address may just say Default.
7. Click Edit
8. Enter the DNS name in the Host Header value field.

I do have a question, however. Do you already have a record for
wss.companyname.com created in DNS?

Answer #4    Answered By: Emmett Hyde     Answered On: Nov 06

I have been occupied elsewhere and not responded.

Two additional points:

1. Host Headers do not have to be FQDN, host name only is supported.

2. HTTP and HTTPS have separate configuration for IP and Host Headers and can be unique (read: different)

Answer #5    Answered By: Michelle White     Answered On: Nov 06

yes, I already have a host name in DNS. And it is
wss.intranet.companyname.com. And this is the same host header name I
entered in the Sharepoint(80) under IIS manager. And also this is the
same name I entered 'Alternate access  mapping'. But no luck. Why?

Answer #6    Answered By: Sheena Ray     Answered On: Nov 06

I really hate to say this, but you might have to just blame it on
being a beta  product. You might have gone through a series of steps
that Microsoft didn't intend on yet, which could cause this issue. I
would also recommend that you upgrade to the Technical Refresh, since
you mentioned you had not upgraded yet. If you have the resources, I
would recommend reinstalling your OS or setting up another dev server
and trying again. I can't tell you how many times I've installed
MOSS in the last month.