MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Alerts Permissions Issue: PermissionMask check failed

  Asked By: Dianna    Date: Jan 17    Category: MOSS    Views: 3892

I have an issue with MOSS 2007 alerts not being sent on my server. I
think I have it narrowed down to a permission issue. That is becasue
I know SMTP workes and has been tested with TELNET to replay
messages. And TIMER picks up the record to process, because
in "EventCache" the "EventData" and "Acl" are set to <null> in 5

I looked at the MOSS logs and ran as "verbose" and found the
following records when I try to send alerts using my master SSP
account <domain>/ssservice (and I also tried with farm account
<domain>/farmservice). Both get this error. And I tried this on
serval MOSS sites with custom authenticators and Win auth.

OWSTIMER.EXE (0x1708):
(1) PermissionMask check failed. asking for 0x00000001, have
(2) Alertsjob results for immediate delivery: 1 prematches, 1 passed
filtering, 0 of 1 passed security trimming, 0 final after rollup

I looked those up in Shareoint Object model and found this:
Value: 0x00000000. Has no permissions on the Web site. Not available
through the user interface.
Value: 0x00000001. View items in lists, documents in document
libraries, and view Web discussion comments. Groups: Reader,
Contributor, Web Designer, Administrator.

I checked to make sure SSPservice and FarmService has access
everywhere I could think of (DB, Services, Users/Groups on local
machine, Active Directory, Component Services) and can't find

Does anybody have an idea at what level in the MOSS infrastructure
this permission issue might be arising from? Where else can I chaeck
to make sure the account has the right permissions to trigger this

Any ideas would be appreciated. I read every article on Google I
could find and still no resolution.



2 Answers Found

Answer #1    Answered By: Brooke Lewis     Answered On: Jan 17

I'm not familiar with that particular error, but in general your timer
account will need access full access to everything, including the
content. Typically you run it as the same user as your app pool to
accomplish this. It may also be that you are running into an issue  with
security trimming of the content - the user(s) signed up for the alert
must have permissions  to at least view the content item or no alerts
will be sent.

Answer #2    Answered By: Talia Johns     Answered On: Jan 17

I had the infrastructure set up correctly, as per your thoughts. It
was "security trimming of the content" issue. The user didn't have
the correct rights.

Didn't find what you were looking for? Find more on Alerts Permissions Issue: PermissionMask check failed Or get search suggestion and latest updates.