MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Adobe's 64-bit PDF iFilter

  Asked By: Emanuel    Date: Jan 18    Category: MOSS    Views: 911

I have a small farm -- one MOSS box with all services, and one SQL Server
box. I've installed the iFilter (version 9) on my MOSS machine, added the
file extension in File Types and the icon so it shows up properly,
stopped/started the Search Service and IIS, and initiated a Full Crawl...
and after all that, I'm still not indexing the contents of PDF files.

What am I missing?



6 Answers Found

Answer #1    Answered By: Lynsey Carver     Answered On: Jan 18

You also have to add it to the files  that you index.

Answer #2    Answered By: Richard Allen     Answered On: Jan 18

I had already added  the extension  in Search
Settings ->File Types.

Turns out that I had to change the actual GUID in the registry, as specified
in their document. Once I did that, and then once again stopped/started
search and IIS, it started crawling PDFs.

Answer #3    Answered By: Ian Davis     Answered On: Jan 18

If you had multiple servers, it only needs to go on the
server that's doing the actual indexing. The other WFEs you just need to add pdf
to docicon.xml, and make sure you have the pdficon.gif (or whatever you named

Answer #4    Answered By: Jagjit Hui     Answered On: Jan 18

Right. I've done this before, but I don't remember having to hack the
registry. Seems like a strange way to install a product.

Answer #5    Answered By: Alexia Mccarty     Answered On: Jan 18

Did you go through the registry and verify all the correct entries are in there?
In almost every install I have done, I end up having to tweak them to get it to

Answer #6    Answered By: Laquita Mcgowan     Answered On: Jan 18

This has been resolved (see follow-up
posts); it was indeed a registry hack. Seems ridiculous, but there it is.

Didn't find what you were looking for? Find more on Adobe's 64-bit PDF iFilter Or get search suggestion and latest updates.