Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Added new WFE server but keep getting webpage cannot be found

  Asked By: Anil    Date: Nov 22    Category: Sharepoint    Views: 6278

We have a farm with one WFE, one app server, and SQL cluster. Our
external sites are setup to use forms authentication and we also have
windows auth sites that are internal that are used with SSPs for
crawling. We also have Reporting Services installed and configured on
the WFE. External sites are secured and i have the certs installed on
the WFE server.

For load-balancing purposes, I have recently added a new server into
the farm. It is showing up in the list of my servers in the farm and
i have 'Office ShrePoint Server Search' and 'Windows SharePoint
Services Web Application' running on this server. When i enabled
WSSWebApp, it created all of the IIS entries on my new server and
created all of my virtual directories. I have added host entries for
my sites to 127.0.0.1 so that i can test the apps to make sure
everything is working. But nothing appears to be working. I keep
getting Web Page cannot be found error..http 404 error.

Since we have lots of customizations done on these apps, i have even
tried copying all of the files from the virtual directory of the
working WFE to the new one but nothing seems to help.

What am i doing wrong? Am i missing some steps? What do i do next?

Share: 

 

6 Answers Found

 
Answer #1    Answered By: Kelvin Mckinney     Answered On: Nov 22

So I take it that you are using host  headers. If using host headers
make sure that in your hostfile you place an entry for each webapp and
it points back to the localhost. If you are using IP addresses for the
web apps, then you need to place those IP addresses in your hostfile.

Remember to flush your DNS, this is an important part.

Copying the files was not really the move I would have taken,
sharepoint makes sure it does that. Are you using NLB or a load balancer?

 
Answer #2    Answered By: Gaurav Ghosh     Answered On: Nov 22

In my host  file, i am pointing those URLs to 127.0.0.1 as my Host
Headers was set to 'All Unassigned'. I also tried assigning a given
IP and made the changes in hostfile to point it to the new IP but now
i am not getting anything. It is acting like i dont' have access to
the internet and i do as i am able to browse external  sites.

I have tried flushing my DNS but that did not help.

The reason i copied the files manually because we have alot of custom
DLLs, etc and it does not copy everything over. From what i know, it
only copies stuff that is in the sharepoint_config file. Can someone
please confirm?

Any sugestions would be very much appreciated. I am not sure what to
do.

 
Answer #3    Answered By: Katelynn Donovan     Answered On: Nov 22

As i was troubleshooting, i stopped the 'Windows SharePoint Services
Web Application' and 'Office SharePoint server  Search' services  that
were running  on this WFE server.

I then rebooted the server and tried starting the 'Windows SharePoint
Serviecs web  Application' again to basically start over the
synchronization process of all of the IIS sites/virtual directories,
etc. But I received the following error:

"An object of the type
Microsoft.SharePoint.Administration.SPServiceInstanceJobDefinition
named "job-service-instance-c6d80edb-45e4-4817-abbb-e329a6b1a6d4"
already exists under the parent
Microsoft.SharePoint.Administration.SPTimerService
named "SPTimerV3". Rename your object or delete the existing object."

I looked at the objects table and found  an entry in there with this
instance id. I looked at the dependencies table to see what the ID
was that it was depending on and i then performed a search  on the
dependencies table for the 'DependengID' and there are 2 entries  in
there. One for the instance id above that is part of the error and
another one. I think i saw this error when i initially started this
server after i added  the farm  and i didn't think anything of it and
started the service using stsadm tool b/c i thought it was probably
complaining due to one of the timer jobs.

My question is what would happen if i were to delete the entry from
the dependencies and the objects tables in SharePoint_Config
database? I hope it won't take my server/farm down. Unless someone
knows the answer to this, i don't want to start deleting stuff out of
the database and cause the production environment to be down.

 
Answer #4    Answered By: Geraldine Slater     Answered On: Nov 22

the page not found  error could be from a missing site defition. i mention this
as you have dlls that weren't packaged as a solution, so you could be missing
other dev-type stuff as well. post SP1, it gives you a page not found when
missing the site def.

 
Answer #5    Answered By: Gail Richmond     Answered On: Nov 22

ok, this really looks like a missing site definition...I just noticed you said
'lots of customization done on these apps'. check to see that all site templates
in the 12 hive..\templates directory exist on the new WFE.

 
Answer #6    Answered By: Ramona Solis     Answered On: Nov 22

That is one thing i have not checked. I will do that tomorrow.
Thanks for the info. I really appreciate it.

 




Tagged: