Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Adbode PDF iFilter w/ MOSS 2007

  Asked By: Emilio    Date: Oct 11    Category: MOSS    Views: 1655

Has anyone had any luck getting the v 8.1 PDF iFilter to work with MOSS
2007?

Share: 

 

22 Answers Found

 
Answer #1    Answered By: Katy Patton     Answered On: Oct 11

I am glad you asked that question, it is on my to do list for today.

 
Answer #2    Answered By: Ana Payne     Answered On: Oct 11

v8.1? When did that come out? Where did you find it? The most current
one on the Adobe site is 6.0, which we have working on MOSS 2007.

 
Answer #3    Answered By: Hema Hegde     Answered On: Oct 11

Ok, since I originally asked the question:

I found a MS KBB about configuring the pdf  iFilter v5.0... Adobe has a
version 6.x on their website for download, and the KBB Article # 832809
shows exactly how to install it to work with moss  2007. I did find that
I needed to just reboot the server for it to work, as restarting osearch
did not work to get it running properly.

Then I found another article about getting the ifilter  in Acrobat 8.1
Reader to work with MOSS 2007:

blogs.msdn.com/.../indexing-pdf-documents-
with-adobe-reader-v-8-and-moss-2007.aspx

The problem is that it didn't work for me! So I'll be curious to know
if it works for anyone else.

The basics are that the iFilter no longer comes as a separate product,
it's part of Acrobat 8.x Reader / Pro. So you need to install reader v8
or later...

I'm not sure if v6.x of the iFilter is eventually going to be a problem
with pdf's created on a newer version of an Adobe product...

 
Answer #4    Answered By: Lacey Daniels     Answered On: Oct 11

Just a pleasant reminder from your friendly neighborhood ghost (here one
minute, gone the next), that there is no x64 edition of the iFilter yet
(that I know of). So if you're trying to get it working on a Win2k3 x64
machine.

 
Answer #5    Answered By: Megan Martin     Answered On: Oct 11

There is an ifilter  for x64 here is the link to it.
http://www.foxitsoftware.com/pdf/ifilter/

 
Answer #6    Answered By: Donta Kirkland     Answered On: Oct 11

That might be why my virtual server locked up during the installation of
adobe ifilter  6.0...

 
Answer #7    Answered By: Cade Velazquez     Answered On: Oct 11

The Foxit iFilter works like a charm on x64 - well worth the few hundred for
the license.

 
Answer #8    Answered By: Ariana Christensen     Answered On: Oct 11

I was told that the version of win2003 server is x32..

Wondering why it locked up..

 
Answer #9    Answered By: Darrius Whitfield     Answered On: Oct 11

I haven't had a chance to try it on a 64 bit machine yet, but reader 8.1
is supposed to contain support for x64. If we can get iFilter working
with it there may be a Free alternative for x64 again. Right now your
only choice is 3rd party pdf  iFilters.

 
Answer #10    Answered By: Adrienne Greene     Answered On: Oct 11

In Acrobat Pro, you can select the target PDF version for each document
type that you convert. We have selected to convert all of our documents
to v1.4, which can be read in Reader 5.0 and later and indexed with
iFilter 5.0 and later. Some of the new PDF features require newer
versions, so some publishers will no doubt be creating PDFs in these new
formats. So, depending upon how much control you have over the PDF
documents in your repository (Are they coming in from outside? Can you
negotiate which version your authors produce their documents in?), you
may or may not have a problem.

When we ran iFilter 5.0, documents arriving from outside and produced
with Acrobat 6.0 (PDF 1.5) would not index. I expect that your first
document produced using PDF 1.6 will not index with iFilter 6.0.

 
Answer #11    Answered By: Joshuah Huber     Answered On: Oct 11

Anyone has luck to have the pdf  icon displayed correctly in the document
library or search results? PDF iFilter 6.0 works great but I could not
get the icon works for me. The image has been put to the correct
location and the XML file has been edited correctly.

 
Answer #12    Answered By: Ciara Collier     Answered On: Oct 11

Same issue here I get moss  to index pdf  properly but the icon does not
display properly I have done this both in x32 and x64 and neither one works
yet.

 
Answer #13    Answered By: Keenan Whitehead     Answered On: Oct 11

Take a look at http://support.microsoft.com/kb/832809. It applies to the
v6.0 iFilter as well.

 
Answer #14    Answered By: Trisha Wheeler     Answered On: Oct 11

The image file and docicon.xml change needs to be made on all web front ends if
you have a multiple server farm.

 
Answer #15    Answered By: Dameon Dejesus     Answered On: Oct 11

In terms of getting the image to display properly, make sure that you're
inheriting permissions properly. If all else fails, recycling the
application pool helps too

 
Answer #16    Answered By: Tejaswani Barve     Answered On: Oct 11

I had the same problem with the icon I created not displaying: It was
the file permissions.

Go up one level, right click on the properties of the folder, go to
security, advanced, and make all child objects in the directory inherit
the directory's permissions.

That will probably fix the issue...

 
Answer #17    Answered By: Harshita Padwal     Answered On: Oct 11

Tried it, still does not work.
I have tried to modify other entry to replace the picture with my pdf
icon. For example, I changed
<Mapping Key="zip" Value="iczip.gif" OpenControl=""/>
To
<Mapping Key="zip" Value="icpdf.gif" OpenControl=""/>
It worked. The pdf  icon displays for zip files.
I also have the following line in the DOCICON.XML file, but icpdf does
not show up.
<Mapping Key="pdf" Value="icpdf.gif" OpenControl=""/>
It is really weird. BTW, the full text index of PDF works.

 
Answer #18    Answered By: Jennifer Jones     Answered On: Oct 11

I have the same issue, I did change the permission on the folder and still
does not display the icon.

 
Answer #19    Answered By: Annie Norris     Answered On: Oct 11

Not sure you need the opencontrol there in that statement..

 
Answer #20    Answered By: Chadd Hahn     Answered On: Oct 11

finally figured out the reason. I got the property name "Value"
lowed cased. The "V" has to be upper case to work.

 
Answer #21    Answered By: Cheryl Kelley     Answered On: Oct 11

As I remember the icon only displays correctly if you use an image whose
resolution is already 16 X 16. It also can't be and ICO. I normally
use a 16 X 16 GIF and it works fine after putting the entry in
Docicon.xml and resetting IIS.

 
Answer #22    Answered By: Titus Sweet     Answered On: Oct 11

Finally I was able to figure out what was wrong, in my docicon.xml file
there two pdf's extensions and I had to rename the icpdf.gif to match the
one that was there. icpdf16.gif so now all icons show.

 
Didn't find what you were looking for? Find more on Adbode PDF iFilter w/ MOSS 2007 Or get search suggestion and latest updates.




Tagged: