Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Accessing SPS Web Service Problem

  Asked By: Charmaine    Date: Dec 19    Category: Sharepoint    Views: 1192

We created a web part. In the webpart we are trying to access the web service.( http://server/subarea/_vti_bin/lists.asmx).
This webpart is working properly in the development server.

but in the production server. Then we are getting the following error:
The request failed with HTTP status 401: Unauthorized.

Really it is urgent. In all the servers it is working fine. but in production server it is giving the above error.

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Cade Velazquez     Answered On: Dec 19

Wondering if this has to do with the trust level defined in the web.config file.

 
Answer #2    Answered By: Ariana Christensen     Answered On: Dec 19

I even tried by defining the trust level as Full.. Even though it is not working.. We tried in all the possible ways as far i know..

Do anyone faced this problem  ever. and if you face. please give us a possible solution..

I am counting on this group very much..

 
Answer #3    Answered By: Darrius Whitfield     Answered On: Dec 19

We created  a webpart, In that webpart  we are accessing  the sharepoint list using the sps  web service. /_vti_bin/lists.asmx.

In all the servers it is working  fine. but in the production server  we kept the same webpart, it is giving error
The request  failed with HTTP status  401: Unauthorized while accessing from the client server.

If we enable the anonymous authentication on the portal it is working fine.I am able to retrieve the data from the webservice.

Did anyone face anyone similar issue.. If yes, please give us a solution.

 
Answer #4    Answered By: Adrienne Greene     Answered On: Dec 19

Check the authent options in IIS for vti_bin. It is probably not using you
alternate authent mechanism.

 
Didn't find what you were looking for? Find more on Accessing SPS Web Service Problem Or get search suggestion and latest updates.




Tagged: