Logo 
Search:

Sharepoint 2010 Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint 2010       RSS Feeds

Access Denied for everyone - even Site Collection Adminstrator

  Date: Nov 01    Category: Sharepoint 2010    Views: 6440

We have SP2010 Server with 3 web app - Intranet, Central Admin, My Site.
This week, Intranet gave everyone access denied error on home page, and
403 error on other pages. But the other web app are fine.
We have publishing feature on intranet & got this error in the log:

02/11/2012 04:34:05.72 w3wp.exe (0x0FE0) 0x0C84
Web Content Management Publishing
8vzh Unexpected PortalSiteMapProvider was unable to fetch
current node, request URL: XXXXXXXXXX/Document
Library/Forms/AllItems.aspx, message: Thread was being aborted., stack
trace: at System.Threading.Thread.AbortInternal() at
System.Threading.Thread.Abort(Object stateInfo) at
System.Web.HttpResponse.End() at
Microsoft.SharePoint.Utilities.SPUtility.Redirect(String url,
SPRedirectFlags flags, HttpContext context, String queryString) at
Microsoft.SharePoint.Utilities.SPUtility.RedirectToAccessDeniedPage(Http\
Context context) at
Microsoft.SharePoint.Utilities.SPUtility.HandleAccessDenied(HttpContext
context) at
Microsoft.SharePoint.Utilities.SPUtility.HandleAccessDenied(Exception
ex) at Microsoft.SharePoint.Library.SPReques...
b701d8df-888f-4d31-ad69-ef027ca2259e
I tried:

- Reboot both front end and database server

- Reset IIS front end & application server

- Confirm there’s over 200GB space on database server

- Confirm content database is online & NOT read only

- Confirm in Central Admin, the site collection is NOT locked &
NOT read only.

- Confirm the superuser & superreader accounts are in the User
Policy for the web app (confirm in Central Admin and powershell)

- Changed the site collection administrator to FARM account,
still got error

- Tried extend the web app to another zone, and got the same
access denied error

I gave NT Authority\Authenticated User with Full Read
Access to the web app in Central Admin(User Policy), the site is back up
& everyone have access.

Share: 

 

5 Answers Found

 
Answer #1    Answered On: Nov 01    

Check your SetSiteLock setting. I had a similar thing happen in a 2007 site. I
hunted for days. Turns out a backup was running and MS automatic updates kicked
off and eventually rebooted the server. The first thing the backup does is set
the sitelock to readonly, which evidently locks out people without the proper
permissions.

 
Answer #2    Answered On: Nov 01    

Checked! It's set to not locked!
Window update was turned off too, no update was applied.

 
Answer #3    Answered On: Nov 01    

You may want to check the user credentials that that application pool is
running under.

If that password is expired, account was suspended or any such thing you could
get this behaviour.

 
Answer #4    Answered On: Nov 01    

Accounts were fine.
But we found out the Super Account & Super Reader in the User Policy was
incorrect, as soon as we change to the proper Super Account & Super Reader,
everything is back to normal.

 
Answer #5    Answered On: Nov 01    
 




Tagged: