Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

401 Unauthorized, nothing helps to fix it

  Asked By: Luz    Date: Feb 24    Category: MOSS    Views: 3408

I'll start with my configuration first. Server3 is the Main SharePoint 2007 Server. It contains the central administration page. Server 4 is my SQL 2008 Server instance (SERVER4\SQL08InstanceName). Report Server is also installed on Server4. Now I will explains so far what I have done and what it has netted me. The SQL Server is set to run as a Network Service. Report Server is set to use MyDomain\SQLRpt. I have set that user as trusted for delegation in Active Directory, it is setup in the SQL OU, no SPN on the account. Now before I went to the Report Server Creation, I installed the Web-front end onto Server4. I then setup my Users for my upcoming sites (MyDomain\SharePointWebA and MyDomain\SharePointWebB) I then created my 2 currently needed Web Apps in SharePoint (SharePoint on Server3 port 80, NTLM, No Anonymous, no SSL, default zone, MyDomain\SharePointWebA w/ correct Password, restart IIS Automatically, Server4\SQL08InstanceName WSS_Content, Windows Authentication; SSRS on Server4 port 1440, NTLM, No Anonymous, No SSL, default zone, MyDomain\SharePointWebB w/correct Password, Restart IIS Automatically, Server\SQL08InstanceName WSS_Content_f1807a4f36c14e738c015040e2bcdc04, Windows Authentication). I then went in and created a site on for Server4:1440 with the url: server4:1440/sites/ReportServer. After this I installed rsSharePoint_x64.msi on both Server3 and Server4. They both installed completely with no errors. After this I loaded up the Resport Server Configuration Tool on Server4. First thing I did there was Enter in my user and password (MyDomain\SQLRpt), hit apply and went to the Database Tab and Made a SharePoint Integrated Database (ReportServerSharePointMode) then hit apply. From there I went to the Web URL Tab and in virtual directory I have ReportServer_InstanceName, All Assigned, 1440. I then Hit apply there. After this I went back to Server3 and logged in as the Administrator. I then hit Manage Integration Settings and inputed Server4:114/ReportServer_InstanceName, Windows Authentication. Hit apply. And get the following:
Server was unable to process request. ---> The request failed with HTTP status 401: Unauthorized.

I tried again, this time Trusted Account and recieved the same. After that I began looking at the following sources:
msdn.microsoft.com/en-us/library/ee384252.aspx section 5.4
http://support.microsoft.com/kb/871179
technet.microsoft.com/en-us/library/cc263449.aspx

During which point I have added the following SPNs (SharePointWebA - http/Server3.MyDomain.com, http/Server3; and SharePointWebB - http/Server4.MyDomain.com, http/Server4)

After all this I still get the above Error Message when I try this. I have even tried inputing Server4:1440/sites/ReportServer/ReportServer_InstanceName. I am at the end of my wits trying to figure out all this authentication stuff. This has been going on for several days and I have had to reboot the servers several times. I have been following this web page to configure all this. technet.microsoft.com/en-us/library/bb326213.aspx.
Can anyone see where I might have gone wrong?

To rebrief my configuration again:
Server3 - Windows Server 2008 R2, SharePoint Server 2007. Server4 - Windows Server 2008 R2, SQL 2008. And my Windows Firewall Port is open between those two for that particular port.

Share: 

 

1 Answer Found

 
Answer #1    Answered By: Ranu Badhan     Answered On: Feb 24

Yes, usually, the error is due to improper authentication method used.
By default, the report server site will be set up to use Kerberos. If you haven't set up Service Principal Names (SPNs), you will get 401  when trying to hit "Set Server Defaults" link in Central Administration site.

As you have tried to set SPNs and configure Kerberos, but cannot resolve your issue, please try to change the Report server site to use NTLM:
Open a command prompt and change directories to C:\Inetpub\AdminscriptsB. Run the following two commands:
i. cscript adsutil.vbs set w3svc/'WebSiteIDForSSRS'/root/NTAuthenticationProviders "NTLM"
ii. cscript adsutil.vbs set w3svc/'WebSiteIDForSSRS'/NTAuthenticationProviders "NTLM"

Note: 'WebSiteIDForSSRS' should be replaced with the identifier for the SSRS web site. The easiest way to find this is to open IIS manager and click on the Web Sites folder in the left hand pane. In the right hand pane you will see the 'Identifier' listed for that web site. The Default Web Site usually has the Identifier of 1.

If your issue continues to persists, could you please try to use Network Service account to configure the Reporting service and let me know the result?

Other reference:
Configuring Reporting Services for SharePoint 3.0 Integration (technet.microsoft.com/en-us/library/bb326356.aspx)

 
Didn't find what you were looking for? Find more on 401 Unauthorized, nothing helps to fix it Or get search suggestion and latest updates.




Tagged: